0

I would like to be able to use mklink without the inconvenience of right-clicking on cmd.exe and choosing "Run as Administrator". I am logged in at work as a domain user with local admin privileges, and UAC is enabled.

I have added the following to "Create Symbolic Links" in "User Rights Assignment" in Local Security Policy: Administrators, Users, OURDOMAIN\MyUsername.

I then logged out and back in.

When I type WHOAMI /PRIV it still doesn't show SeCreateSymbolicLinkPrivilege.

What am I doing wrong (or failing to do)?

0

If you're trying to create a symbolic link on a local directory, then it's possible domain policy is overriding the local policy you set.

  • Thanks, Wohlfe. Yes, I'm trying to creates purely local symlinks - to a file in my own directory on my C: drive. So is there anything I can do other than ask the network administrator to give me the privilege through a domain policy, even though this is just for use on my local machine? – Klitos Kyriacou Mar 21 '15 at 17:26
-2

Setting Create Symbolic Link privilege in Secpol has no effect if your user is in the Administrator group. This has been answered in quite a few places already. Here's one: How can I create symbolic links in Windows 8.1 without an admin command prompt?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.