1

I am using Windows 8.1 and I have about 30 important Windows updates. It seems I can't have any of them get updated without failing and getting a "We couldn't complete the updates.. Undoing changes". Even when I choose to update just a single update, Windows tries to update a whole bunch of them. I am sure if this because of dependencies or what. Also when I try to hide all of them, at some point they come back and Windows shows them again and the cycle repeats.

I also used a tool from Microsoft which supposedly fixes Windows update issues. It reports it fixed errors but every time I run it, it says it fixed errors. If it fixed the errors then why is it still saying it fixed errors after each run. It doesn't matter how many times I run it or if reboot. I feel it's not a reliable tool.

What's the process to troubleshoot the failed updates? I feel the updates are just piling up over time and I am stuck. I want either the updates to be hidden for good (unless I specifically show them again) or get installed correctly.

  • Anything in the Event Logs regarding the failed updates (like an actual error code)? Try the basics: Stop the Windows Udpate and Background Intelligent Transfer (BITS) services. Go delete the c:\Windows\SoftwareDistribution folder, Start the Windows Update service again, and try updating. Any difference? – Ƭᴇcʜιᴇ007 Mar 20 '15 at 16:30
  • Windows 8 requires a number of folders and files exist in their standard locations for update to succeed. After I had deleted some folders, updates failed. See chentiangemalc.wordpress.com/2014/04/03/… for more information. Hope this helps... – DrMoishe Pippik Mar 20 '15 at 18:52
  • share the folder C:\Windows\logs\CBS. I'll take a look at it – magicandre1981 Mar 20 '15 at 19:28
  • @Ƭᴇcʜιᴇ007 It didn't help – Tony_Henrich Mar 21 '15 at 18:07
  • Anything in the Event Logs regarding the failed updates (like an actual error code)? – Ƭᴇcʜιᴇ007 Mar 21 '15 at 18:07
2

You get the error 0X8004402f which means "Error creating temporary file". I found this Blog post which says this can happen when TEMP folder is not configured correctly. So set the TEMP folder back to a local folder on C: instead of using a RAM disk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.