15

I am using Chrome and this just happens in Facebook and just for YouTube videos (HTML5).

When going fullscreen it shows the video in for a second and than the video disappears and I see the Facebook page in fullscreen with the "www.facebook.com is in now full screen. Exit full screen ESC" message on top. I can click links but the page will not scroll. Pressing ESC exit the fullscreen mode and I can continue watch the video in the standard size.

When opening the same video on the Youtube page there is no problem to go fullscreen.

No problem watching Youtube videos in fullscreen from other sites.

Has anyone else experienced this problem and found a solution?

  • Happens to me too, but only about 95% of the time- sometimes it works. My solution is to open in new tab - on youtube.com url – Spikolynn Jun 15 '15 at 15:55
  • It is just another movement of the Facebook video war against Youtube – Daniel G. Blázquez Sep 23 '15 at 1:09
7

This also started happening to me after I went from Chrome 39 to 41. The problem appears to be a bug, as reported here.

2

I was having the exact same issue. The only solution I could find was to set YouTube to use Flash by default instead of their HTML 5 player.

  • Please provide more details. How do you set Youtube to use Flash by default? – Shay Fertig Mar 25 '15 at 10:38
  • 1
    There used to be a setting in YouTube allowing you to choose between HTML 5 and Flash but they recently removed it. Thankfully though there is an extension on the Chrome web store that still allows you to do it, it's called Disable YouTube HTML5 Player and it can be found here – Joe Kiernan Mar 25 '15 at 10:58
  • Found it. Problem solved! Thanks!!! Does anyone knows what are the other consequences of not using HTML5 for Youtube? Is there a way to disable it just under Facebook? – Shay Fertig Mar 25 '15 at 11:05
  • From a user perspective, all videos hosted by YouTube can be played in both the Flash and the HTML 5 player at the same bit rates and resolutions, so there really isn't any consequences to disabling the HTML 5 player. In fact if you are on a Windows based PC, you may see slightly less CPU usage using the Flash player. YouTube just wants to make the HTML 5 player the default player as it supports more mobile devices than Flash. – Joe Kiernan Mar 25 '15 at 12:43
  • I wish I could switch back to the Flash player, but I cannot find it anywhere in youtube. – Triynko Jun 18 '15 at 2:25
0

In google help forum I found out that it may help to zoom tab to 100% (which did not work for me), or you could disable hardware acceleration in Chrome/Chromium in advanced settings (which worked for me on one hardware, but invoked screen tearing). Oddly after switching hardware acceleration back on, fullscreen works. (This was with Nvidia proprietary graphics driver.)

protected by Community May 25 '15 at 23:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.