3

I edited ["HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings"] and set the administrator permissions to "Deny".

Now, when I try to open any file it gives me this message:

"Your Internet security settings prevented one or more files from being opened".

Any solutions?

1
  • yeah, in windows its never safe to take admin access from much of anything, except files, which is ineffective since admins can always take ownership. you can try editing the registry offline: raymond.cc/blog/… Mar 22, 2015 at 6:21

2 Answers 2

4

Sysinternals Suite - PsExec.

Run regedit at SYSTEM right:

psexec -i -d -s %windir%\regedit.exe

Run regedit at SYSTEM right Windows 2003/XP:

ntsd -c qd regedit
1
  • Or navigate to that key. Go to Permissions -> Advanced. Go to Change Owner ship. Take ownership. Then remove the deny permission
    – Ganesh R.
    Mar 22, 2015 at 14:17
0

The main problem is that your using Windows Explorer, which is closely linked to Internet Explorer, as shell to run regedit.exe. A workaround is to use the command prompt to run regedit.exe. Just follow these instructions:

  1. Run the command prompt by pressing the Windows key and R simultaneously.
  2. Type regedit.exe in the command prompt and execute it by pressing Enter.
  3. The registry editor appears. Undo your change of the permission of the registry key using the registry editor.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.