0

I copied some files from another computer to my western digital external hard drive and then after I connected it to my PC Windows can't recognize my NTFS drive.

A few month ago I changed partions to have 1 NTFSdrive and 1 FAT32 drive. The FAT32 drive is good but windows does not show my NTFS drive neither Ubuntu.(gparted says it's file system is broken or something like that error!)

enter image description here

  • This is probably a clue: "(gparted says it's file system is broken or something like that error!) " – Xavierjazz Mar 22 '15 at 17:12
  • so what can i do? can i recreate ntfs filesystem without losing data? because i can't access my files to backup them – Sina Moradi Mar 22 '15 at 17:13
  • here a picture from gparted, please someone help me with this craplink – Sina Moradi Mar 23 '15 at 20:03
  • i did not run any of these software: testdisk or chkdsk /f, what should i do? – Sina Moradi Mar 23 '15 at 20:07
  • You should run chkdsk/f as suggested. Once that's done and you have restored access to your files it's not bad to run WD DLG to test the HDD health products.wdc.com/support/kb.ashx?id=6krRkb . – Techpumpkin_WD Mar 24 '15 at 15:08
1

According to the screenshot you linked to, gparted is telling you:

Warning:
ntfs_mst_post_read_fixup_warn: magic: 0x44414142 size: 1024 usa_ofs: 24474 usa_count: 46079: Invalid argument
Record 0 has no FILE magic (0x44414142)
Failed to load $MFT: Input/output error
Failed to mount '/dev/sdc1': Input/output error
NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
The usage of the /f parameter is very IMPORTANT! No modification was made to NTFS by this software.

Unable to read the contents of this file system! Because of this some operations may be unavailable. The cause might be a missing software package. The following list of software packages is required for ntfs file system support: ntfsprogs / ntfs-3g.

This appears to me to be clear signs of file system corruption. Maybe the disk was unplugged before the system had finished writing data to it, or maybe there is some physical problem with the disk itself. The latter can happen if the disk is exposed to sudden vibration or accelleration while working.

You'll also notice that the warning message gives you a clear course of action: "Run chkdsk /f on Windows then reboot it TWICE!"

I would recommend that you do that, and once you have done that, retry the operation. If it still doesn't work, consider copying the data elsewhere, reformatting the partition and copying the data back onto it. Remember that Linux NTFS support is still somewhat spotty and may have rough edges; for interoperability, unless you absolutely need the ability to store files >4GiB in size, you're probably better off using FAT32.

|improve this answer|||||
  • yes. i get it.i will do that, but my main problem is that i can't access any of my files, so how backup them? (i will check with chkdsk /f and write the result asap here, please stay with me!) – Sina Moradi Mar 24 '15 at 10:38
  • chkdsk /f did not worked for me.what should i do now? – Sina Moradi Mar 25 '15 at 12:52
  • how can i use testdisk for this? is there a damaged ntfs recovery guide? – Sina Moradi Mar 25 '15 at 12:53
  • @user22669 That does not request clarification or suggest improvement to this particular answer. If you have further questions based on what this has uncovered, please ask a new question. Also see the data-recovery, partition-recovery, file-recovery and hard-drive-recovery tags. – a CVn Mar 25 '15 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.