3

I am running Windows 8.1 Pro 64-bit on a ThinkPad Yoga, which as no built-in optical drive. The ThinkPad's BIOS, drivers, and Windows updates are all the latest available.

When I connect my ASUS SBC-06D2X-U Blu-ray drive to the ThinkPad, the drive does not show in Windows Explorer or Device Manager like I would expect. Windows beeps to acknowledge that I plugged in the drive; and the drive gets power: the lights on the drive's tray flash green initially, and I can open the drive by pressing its eject button; but there is no sign of the drive in Windows.

When I connect the drive to another computer (running Windows 7 Pro 32-bit), it works fine.

I checked whether ASUS provides a Windows 8.1 driver for the drive, but it seems like Windows 8.1's generic PnP and driver is all that it requires like I would expect. I also ran the Windows 8.1 troubleshooter, but it found no related problems. And I have searched online for possible causes but not found anything helpful.

Can anyone suggest why this basic Windows functionality seems to be hamstrung in my case and how I can resolve the issue?

6

I had the same issue with Windows 10. The ASUS drive worked fine, then Windows did an update and wouldnt find it. It would beep when plugged in so Windows knew something was there. Uninstalling the "Initio" device and checking the "remove driver" box did it. Right click in device manager and scan for new hardware and it correctly identified it.

  • Incredible, the June 2018 Windows update caused this to happen again. And yet again I use this answer to solve the problem! – Gruber Jun 7 '18 at 18:14
  • Exactly the same issue for me as well. June 2018 update broke everything again. I followed this, and made sure I checked off the option to delete the driver files along with the uninstall of the "Initio" driver. – meltdownmonk Jun 19 '18 at 0:41
2

I was having a similar problem with Windows 10, I tried all the generic solutions, Microsoft supplied troubleshooters, etc...

There were no dvd drive devices appearing in the Device Manager, but your mention of "Initio" pointed me right direction. There was a non-descript entry for "Initio" that I had to this point ignored. I uninstalled it and scanned for hardware and the drive popped up immediately! Many thanks!

  • This is what I did. There was no need to disconnect the external drive, shut down the PC, re-connect the external drive, and re-start the computer as said in the other answer. – kiamlaluno Oct 19 '17 at 15:28
1

Upon double checking the contents of the SBC-06D2X-U's box before throwing it out this evening, I noticed that it did, in fact, come with a DVD-ROM – that I ignored when I bought the drive and started using it with Windows 7 over a year ago.

I put the disc in my Windows 7 machine's DVD-ROM drive and copied its contents to my Yoga, where I ran the setup program and chose to install Turbo Engine:

ASUS Drive Packaged Software

To my surprise, I was subsequently presented with an "Initio"-related driver-installation dialog: I clicked OK (before I considered taking a screenshot unfortunately), and Windows 8.1 immediately recognized the drive. Device Manager revealed the following driver details afterward:

Driver File Details

So the drive now works...with a generic Windows driver as expected no less.

I am a little uneasy about coincidentally resolving the issue, stumbling unwittingly onto a solution, but my dumb luck resolved it regardless.

To the extent I indulged my need to understand more, though, I Bing'd "Windows 8.1 Initio" and found a thread in the Microsoft Community forums speaking to this very issue with this very drive that blamed an "Initio" Windows update; and while the person who asked the question there encountered this issue with Windows 8.1 like me, apparently others have encountered it with Windows 7 too FWIW.

1

This drive that plugs into USB does not appear in Device manager but as a separate line item Initio Combo Device Class Initio Default Controller also, there is no entry in the "USB Bus controllers" to correct that: Desactivate and desinstall the "initionDefault Controller" and the drivers. Unplug the DVD from the USB port - then power off the PC Plug the DVD - and restart the PC. It should be OK now. In the device manager: there is now an entry for Mass storage controller in the "USB bus controller" list, and a new device "DVD/CD-ROM readers"

  • I simply did as @CovertJaguard described, and it worked, without shutting down the computer. – kiamlaluno Oct 19 '17 at 15:29

protected by Community Jun 11 '16 at 18:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.