2

I just got a Kinect 2 and am trying to run it in Windows 8.1. I've connected it to a USB 3.0 port and it appears to be connecting, disconnecting, and reconnecting itself every 2-3 seconds with the taskbar error "USB device not recognized: The last USB device you connected to the computer malfunctioned, and Windows does not recognize it."

As it's cycling, the Device Manager is showing, under USB Controllers, "Unknown USB Device (Device Failed Enumeration)." Right clicking on that entry and selecting "Properties" shows the "Device status" message which is cycling between:

"Currently, this hardware device is not connected to the computer. (Code 45)

To fix this problem, reconnect this hardware device to the computer.

A request for the USB BOS descriptor failed."

and

"Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB BOS descriptor failed."

What I've tried, as per other posts about similar problems:

-turning it off and turning it back on again. I've cycled power for both the Kinect and the computer, and turned the computer off and left it unplugged for a few minutes, then with the Kinect both plugged in and unplugged from the computer, turned on the computer again.

-unplugging it and plugging it back in. See above. Also, plugging a different device in to that USB port results in a working device. Plugging the Kinect into a different USB port yields the same error cycling results.

-when the "Unknown USB device" appears in the Device manager, quickly right click on it and uninstall the device. This does nothing, as it just reappears in a few seconds as it continues cycling.

-opened up regedit to change device parameters. The device was there, but not the variables that this tutorial said to look for.

Has anyone else run into this kind of issue? Any other suggestions?

  • Does the same port always work? The Kinect is new I presume? – Ramhound Mar 24 '15 at 11:49
  • The Kinect was borrowed from school. And yeah, the ports are all good. I actually got it to work by firing up the Windows 7 partition on my computer and letting it install itself there, then I restarted into Windows 8.1 and it worked just fine. So I have no idea why that would make it work, but it did. Thanks anyways. – Steve Eckert Mar 24 '15 at 15:46
1

I got it to work by letting the Kinect install itself to the Windows 7 partition on my computer, then I restarted into Windows 8.1 and it worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.