0

Ever since I downloaded 7zip, and even after I uninstalled it, is that all my zip files are downloaded as 7z files. How in the world can I stop this?! I have been looking for answers for about a month in my spare time and the closest I can find to useful advice is How to stop 7-Zip from automatically downloading and opening a zip file in Chrome? which is not even the same problem. Any help, ideas, notions, educated guesses, or anything else you have that might enable me to have zip files again would be appreciated sooooo much.

So far I have:

  1. Used a reg file to recreate the association to zip files after 7zip deleted them
  2. Tried to set a zip file's default opener to Windows Explorer (it already was there)
  3. Using other browsers
  4. Requiring me to select where to save the file
  5. Reinstalling 7zip and using the settings to ignore zip files

Im using Chrome and Firefox and Windows 8.1

But every time the zip file I click on is listed as a 7z file before the download even begins.

  • 2
    Please don't buy a new computer because of this. – mtone Mar 24 '15 at 0:56
  • Lol I'm just joking. – mario Mar 24 '15 at 0:57
  • I'm just frustrated lol. I don't have a lot of time to work on side projects and I need zip files to work for a gift I've been trying to make for a friend. So this day I've had some free time basically was wasted trying to fix this virus-like application instead of making my friend's gift. – mario Mar 24 '15 at 0:58
  • 1
    Can you post a screenshot of what you mean by "everytime the zip file I click is listed as a 7z file before the download even begins"? Did the uninstall work (can you find 7zip in your start menu?) – mtone Mar 24 '15 at 1:00
  • 1
    Can you add to your question what browsers you've tried and what Windows version you're using? – mtone Mar 24 '15 at 1:34
3

I would suggest that you test by opening zip files on your computer first, NOT in the browser until this works. If it works on the desktop, but broken in the browser, at least you will have narrowed down the problem.

So, here are my suggested step to fix the problem on the desktop.

  1. Follow the instructions here to attempt restoring the file associations. (Sorry I don't have time to copy it all here, I would stop at Step 4 personally).

  2. This could be counter-intuitive, but I would also try to reinstall 7zip again. I noticed the 7zip configuration for file associations improved over time, so if you had an old version it might help to start over again.

    In the start menu, open "7-Zip File Manager", go in Tools...Options. Notice on my computer 7zip is only associated with 7z files, and zip files show "Compressed folder" which is what you want ultimately.

    enter image description here

    Does associating and de-associating change the behavior when opening a zip file on your computer (not browser)?

  3. Do you remember installing 7zip from this website? If you got it elsewhere, I would suggest to install and run an MalwareBytes Anti-Malware just in case you've got something funky.

  • Thanks mtone, I tried those. Good idea about using 7zip settings (I had already reinstalled it) but that didn't help either. And yes, both times I got it from their site. – mario Mar 24 '15 at 1:26
  • 1
    So what happens when you double-click on a .zip file from your desktop (not the browser)? Make sure you have "show file extensions" enabled in your explorer settings for this. – mtone Mar 24 '15 at 1:29
  • It opens in windows explorer like a normal zip file. – mario Mar 24 '15 at 1:30
  • It seems like just downloading a file is the problem – mario Mar 24 '15 at 1:31
  • 1
    Another note, if you're uninstalling something from windows I suggest the use of revo uninstaller, its very good about catching the hinky parts at the end of uninstallation and leaves you with a pretty clean registry and hard drive :) – hanetzer Mar 24 '15 at 2:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.