10

The top menu is wrong (Virtualbox 4.2, Windows 7)

Shows: File, Machine, Help

Expected: File, Machine, Devices, Help

enter image description here

  • How did you get OSX in VirtualBox? – user742864 May 19 at 23:54
6

When in seamless/fullscreen mode, you can hit Host + Home key to popup the toolbar dialog menu.

I know this post is old/may not have been a hotkey at the time, but figured for people visiting trying to find this (as it's high up on search results) it may be helpful!

| improve this answer | |
  • What, exactly, does this have to do with the “Devices” menu not appearing on the menu bar? – Scott Sep 16 '17 at 6:52
  • @Scott it will pop up the guest machines menu when it is hidden – Jonathan Aug 10 '18 at 1:18
3

Please update to the latest version of VirtualBox, version 4.3.26. The Devices menu will normally only be shown at the top of the virtual machine window when a virtual machine is running. You can also also use the keyboard shortcut to insert the Guest Additions CD. By default, to do this, hold down the Ctrl key on the right right of your keyboard, and hit the "D" key.

| improve this answer | |
3

I faced the same issue with MAC host and Ubuntu guest. Finally, I found this:

  1. Go to preferences.

  2. Select "input"->"Virtual Machine" Add shortcut key to "Menu Bar Settings" (I added HOST key + M)

Screenshot

  1. Click "OK" and go to running virtual machine and press the key combination for Menu Bar Settings. Then you can see menu on top of the screen

Screenshot2

| improve this answer | |
2

I had to hit HOST + C to disable stretched display (Right-Control C) and the Devices menu was shown on the Guest window NOT on the Virtual Box window.

| improve this answer | |
0

Had same issue. Discovered that right clicking empty space in the Menu panel will cause a subset bar to show up. Clicking on "Devices" will add it to the main menu bar. Don't know why it's hidden in the first place- wasn't in earlier versions of VM. Hope it works for you.

| improve this answer | |
0

I faced this issue just now. Following are my findings:-

Issue: " Devices menu not visible"

Resolution:

There is actually an option as to what you want to see in the menu for a machine. Make sure 'Devices' is selected here.

enter image description here

| improve this answer | |
  • There is no "devices" in your screenshot. Please explain your answer in more detail. – Ramhound Dec 6 '16 at 15:20
0
  1. go to settings> user interface
  2. click the option device
  3. click ok.
  4. to start the machine, click start.
  5. in the OS that you installed, press host+c

    you will see the option above will appear.

| improve this answer | |
0

In the VM respective machine (Ubuntu 20.04 LTS) General / User Interface must be selected Device like others tabs (File Machine etc Help) and in each one select what you want (Insert Guest Additions CD Image) The you will see the CD and from there install the additional modules with: sudo ./VBoxLinuxAdditions.run

| improve this answer | |
-1

The Menu Settings can be accessed in the 'Settings' (R-Click the VM) then 'User interface' (Tab) Make sure each of the menus are ticked and are slightly greyed and OK and then start/restart VM. This applies to the MAC Version but something similar should work for the other platforms.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.