I have a specific set of binaries installed at:


These were previously working correctly, but for seemingly no reason when I attempt to execute them the shell claims not to find them:

james@anubis:~/.GutenMark/binary$ ls -al
-rwxr-xr-x 1 james james 2979036 2009-05-10 13:34 GUItenMark
-rwxrwxrwx 1 james james   76952 2009-05-10 13:34 GutenMark
-rwxr-xr-x 1 james james   10156 2009-05-10 13:34 GutenSplit
james@anubis:~/.GutenMark/binary$ ./GutenMark
bash: ./GutenMark: No such file or directory

I've tried to isolate the cause of this, with no success. The same happens with zsh, bash, and sh (all giving their appropriate file not found error -- this is definitely not a strange output from the binary itself). The same happens either as user James or as root. Nor is it directory specific; if I move the whole directory installation, or just a single binary, to anywhere else, the same happens when attempting to execute it. The same even happens when I put the directory in $PATH and just execute "GutenMark". It also happens when I execute it from a script (I've tried Python's commands module -- though this appears to just call sh).

The problem appears to be specific to the binaries themselves, yet they appear to never actually get executed.

Any ideas?

  • What does file * show? – liori Dec 30 '09 at 12:36
  • Another good point, but nope. The binary Gutenmark is: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.9, stripped – jameshfisher Dec 30 '09 at 13:39
  • (I should note I meant GutenMark, not Gutenmark, above.) – jameshfisher Dec 30 '09 at 13:48
  • If this is a helpful diagnostic, a new PID is shown before the error if i fork it: ./GutenMark &. – jameshfisher Dec 30 '09 at 13:58
  • I've got around to trying the same binaries on a different system (using scp), and they work as expected there -- i.e., as they were working originally on this system. The saga continues... – jameshfisher Dec 30 '09 at 14:28

Are you are trying to run a 32 bit binary on a 64 bit system or vice versa?
And the same question for any libraries used by these executables.

Or are any used libraries now missing?

| improve this answer | |
  • It's a 32-bit binary and a 64-bit system. The same, presumably for all libraries that came with the package. This is probably not the issue as I've already had the binaries running on this system, and to my knowledge no libraries have been removed since the last successful run. – jameshfisher Dec 30 '09 at 14:26
  • ARGH. Sorry, the problem is now solved, and you were right: libraries had been removed. When the system was fscked around with yesterday by SOMEONE attempting to install flash-player, some low-level libraries were removed. It's presumably one of the following, that I've just installed: ia32-libs lib32gcc1 lib32stdc++6 lib32v4l-0 lib32z1 libc6-i386 Thanks to everyone for help with a problem that wasn't completely described. – jameshfisher Dec 30 '09 at 14:40

Is GutenMark (at 76592 bytes) not actually a binary, but a script starting with a !# line which defines the program which executes the script?

If that line defined a non-existent program, you would see a 'not found' error message.

| improve this answer | |
  • A good point, but no: james@anubis:~/.GutenMark/binary$ cat GutenMark | head --bytes=200 ELF4�(4 (44�4������� ��I �james@anubis:~/.GutenMark/binary$ – jameshfisher Dec 30 '09 at 13:32
  • A related possibility, though pretty far-fetched, is that GutenMark detects the type of shell that is running it, then using it to find a non-existent file. – jameshfisher Dec 30 '09 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.