1

I have three Windows hosts on the same private LAN, each hosting an IIS default website. One host is running Windows 7 Pro, while the other two are running Windows 8.1 Update Version 6.3 (Build 9600).

Other computers on the local subnet can open the default website on each of the 3 hosts by entering each host's private IP address in a browser.

However, when I Port Forward port 80 on a gateway router in turn to each of the 3 hosts private IP address, then enter the public IP of the gateway router into a browser on a computer outside of the private network, only the Windows 7 host displays its default website. The two Windows 8.1 Update hosts report "This webpage is not available. Details: The host took too long to respond." Additionally, no record of the HTTP request appears in "C:\inetpub\logs\LogFiles\W3SVC1\u_exYYMMDD.log" on the host.

All three hosts have their Windows Firewall Inbound Rule "World Wide Web Services (HTTP Traffic-In)" set to Profile: All, Enabled: Yes, Action: Allow, Override: No, Program: System, Local Address: Any, Remote Address: Any, Protocol: TCP, Local Port: 80, Remote Port: Any, Authorized Users: Any, Authorized Computers: Any, Authorized Local Principles: Any, Local User Owner: Any, Application Package: Any.

This problem began after I installed the mid-February Windows Update. Any help diagnosing & fixing the problem is greatly appreciated.

1

Problem solved. It turned out the cause was Check Point VPN v98.60.202, from Check Point Software Technologies. I had installed this software to connect to a corporate client's internal network.

I suspected this was the cause because of how VPNs work, so I had previously closed the VPN software, but that didn't solve the problem. I actually needed to completely uninstall the Check Point VPN software and reboot the computer to remove the hooks it makes into the Operating System's TCP/IP stack. That allowed IP addresses outside of the host's subnet to again be served by IIS 8.5.

1
  • Mark this as an answer then, so that the question doesn't keep appearing on the front page.
    – paradroid
    Mar 26 '15 at 15:25
0

However, when I Port Forward port 80 on a gateway router in turn to each of the 3 hosts private IP address, then enter the public IP of the gateway router into a browser on a computer outside of the private network, only the Windows 7 host displays its default website.

You cannot forward the same port to three different hosts and expect them all the work. Is that what you are doing?

The two Windows 8.1 Update hosts report "This webpage is not available. Details: The host took too long to respond." Additionally, no record of the HTTP request appears in "C:\inetpub\logs\LogFiles\W3SVC1\u_exYYMMDD.log" on the host.

But how are you trying to access these other two hosts, when you are using the public IP address?

You will need the other two hosts have the web servers listening on separate ports, with those ports forwarded from the router.

So you would access the sites on the other hosts with something like:

http://86.166.163.103:8080

http://86.166.163.103:8000

A preferable way to do this, if possible, is to use domain names and have all sites running on the same host's webserver. Then you can use port 80 for all sites (but I am not sure if this is possible on the client versions of IIS).

3
  • Normally each host is on it's own static IP address and router. I'm not trying to forward a single IP/Port to multiple internal servers, just forwarding the same IP/router to one host at a time to ensure that everything else was identical. The issue here is that local (subnet) IP addresses work, but public IP addresses forwarded by the router don't on Windows 8.1. This was working perfectly, but stopped without my changing anything after the latest Windows Update. I've been unable to identify anything in IIS that would distinguish between private and public client IP addresses.
    – Eric
    Mar 25 '15 at 19:20
  • @Eric I see. Have you tried disabling the Windows Firewall, to see if the problem is caused by it somehow?
    – paradroid
    Mar 25 '15 at 19:37
  • Yes, I disabled both Windows Firewall and Windows Defender, but that made no difference. Public IPs continue to be blocked by something that apparently changed in last Windows Update for 8.1, while private IPs on the same subnet as the host succeed.
    – Eric
    Mar 25 '15 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.