3

A reboot seems to fix it, but after logging out (sometimes with the ever-amazing ctrl-alt-backspace, if you can call that logging out) and back in chrome loses audio. The speaker icon on the tab starts, but still no sound. Other apps such as vlc, amarok, paplay etc. work just fine. This seemed to start after updating google-chrome from v39 to v41. I'm using Fedora 21 with KDE. Checking KDE Mixer, there was no google chrome in Playback Streams either.

To narrow down the problem I've killed all chrome windows with killall chrome and run google-chrome from the terminal so I can see its output. Heading to an HTML5 audio test page I get this:

ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

I've tried restarting pulse audio with pulseaudio -k but this doesn't seem to fix anything.

What could the problem be?

3

Getting terminal output from chrome and messing with pulseaudio was the key. Trying to kill and start pulseaudio gave this:

>>> pulseaudio 
E: [pulseaudio] socket-server.c: bind(): Address already in use

Which lead to my answer here:

https://bbs.archlinux.org/viewtopic.php?id=185456

The solution was removing a .esd directory in /tmp and running pulseaudio again:

>>> rm -r /tmp/.esd-1000/
>>> pulseaudio

Not sure why this works, but I instantly had audio back in chrome and haven't had the problem since.

1
  • Thanks, I had this problem since months ago.. I always postponed the issue using firefox... thanks ! Google Chrome Rocks ! But needs hacking help!
    – MadMad666
    Sep 5 '16 at 20:24
0

In my case Google Chrome did not play sound in my speakers because of an extension installed in Chrome, namely "Disable HTML5 Autoplay".

As soon as I uninstalled the extension, Google Meet was able to work as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.