7

when i type chrome://help/ in Chrome's address bar, i get

Version 41.0.2272.101 m Google Chrome is up to date.

but when i try to go to https://twitter.com i get on win8.1:

This web page is not available Hide details The web page at https://twitter.com/ might be temporarily down or it may have moved permanently to a new web address. Error code: ERR_INVALID_CHUNKED_ENCODING

Please note that when i use another computer on my home network, i am able to log on to twitter.

on the win8.1 PC, using internet explorer,
i get a different error for https://twitter.com :

https://twitter.com/sessions This page can’t be displayed
•Make sure the web address https://twitter.com is correct. •Look for the page with your search engine. •Refresh the page in a few minutes.

3
  • Does IE work on the machine that is having problems? It appears Chrome is set to use a proxy based on my research.
    – Ramhound
    Mar 25 '15 at 17:22
  • Chrome and IE share the same proxy settings unlike Firefox. So a good way to verify this is a shared configured problem is to use a browser like Firefox which does NOT use the proxy settings as IE and Chrome.
    – Ramhound
    Mar 25 '15 at 18:03
  • @Ramhound -- you nailed it ... i did not set it up but it's probably residue from using a VPN ... removing the VPN left these settings in place. Thank you. ie and chrome now work as they should. While i've not installed Fiddler4 yet, i've seen similar behaviour in the past where my PC crashes and Fiddler4 did not have a chance to release the proxy for SSL.
    – gerryLowry
    Mar 25 '15 at 19:14
4

Follow These Steps

1) First go to control panel > internet options > Connections > LAN Settings.

2) Then Deselect Use Proxy For Your LAN

ERR_INVALID_CHUNKED_ENCODING

3
  • you comment lead to my fixing it; for that reason, i'm marking this as the answer. i used this to achieve the same result: support.google.com/chrome/answer/96815?hl=en. TIMTOWTDI Thank you again. B-)
    – gerryLowry
    Mar 25 '15 at 21:00
  • I got an error running the ember-quickstart tutorial, and could not load the templates content, until I deselected the Automatic proxy configuration (Windows 10 Settings). Thank you.
    – j4v1
    Nov 15 '16 at 16:45
  • Update: the error is now persistent, and have all this configuration for proxy LAN set up. Not sure what the problem can be, as the webpage I try to display is a localhost one, served with ember.
    – j4v1
    Nov 22 '16 at 14:16
4

For the Chrome error ERR_INVALID_CHUNKED_ENCODING, it can be because of many reasons. For example, if this helps diagnose the problem, I was once sending 0xDE\r\n instead of DE\r\n for the chunk length with chunked encoding. It worked flawlessly with Python's urllib.request and wget. Soon as I used Chrome it with ERR_INVALID_CHUNKED_ENCODING.

The point being that if any specific part of the response is modified by the proxy even when other applications work fine then it is possible you will get this error. It could be an incorrect chunk length or incorrect \r\n delimiters.

The minimal response that works with Chrome currently is:

HTTP/1.1 200 OK\r\n
Transfer-Encoding: chunked\r\n
Connection: <what-is-going-to-happen-to-connection\r\n
\r\n
a\r\n
1234567890\r\n
0\r\n
\r\n

This should help with diagnosing faults for Chrome with invalid chunked encoding errors.

1
  • In my case I was trying to make my nginx conf a bit more readable and added \ns (mac) to the value of my Content-Security-Policy header (via add_header), just putting everything in one line (no line-breaks) fixed it
    – Dr1Ku
    Mar 6 '20 at 7:08
1

My system showed nothing in the Proxy setting, but uninstalling BitDefender Total Security fixed this for me

1

If you are using bit defender go to bit defender settings-> web protection, then off all the security parameters.

1
  • Thank you, this actually helped me, but since I was using Bitdefender free version there is no such option (although it seems the web protection module is running), so after uninstalling, site started working again.
    – Renesis
    Mar 26 '18 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.