My problem in short:

Entering http://app01:8084/ into the browser does not find my server. Entering http://app01.my.domain.com:8084/ does work.

With the localname Wireshark not even captures a DNS request. nslookup can look up "app01" correctly.

The details:

(Windows 7 Ult. 64, VirtualBox 4.3.10, VMWare Workstation 10.0.2)

I have a virtual machine in VirtualBox which contains a rails app. Port forwardings have been set up as localhost:8084 -> vm:80, 8184 -> 443 and 2242 -> 22. I have a Mac OS X Mavericks server (OS X Server) which also is a name server. The nameserver has entries for my workstation like so:

w7ult64.my.domain.com -> Aliases have been added, among others "name1", "app01". (I added "name1" months ago and URLs like http://name1:8084/ work well.)

Now I added the app01 alias and it does not work. I started the browser. I started WireShark to capture all network interfaces. I enter http://app01:8084/ into the browser and it starts spinning its wheels. I look at the Wireshark capture and there is not a single DNS lookup.

I run nslookup from commandline. app01 is resolved perfectly and I see the appropriate lookups in the wireshark capture.

The network interfaces have "my.domain.com" as the dns suffix. ("my.domain.com" only in this discussion - the actual domain is one which I own.)

So I am a little confused why the browser is not able to do, what nslookup can do.

Looking at the wireshark capture, I noticed that when the browser tries to find app01, there are a lot of retransmission entries on a certain network. That network is from virtualbox ("VirtualBox Host-Only Network #5) which is used as a host only network in that actual VM on adapter 2.

What can I do to fix this?

(I also noticed this: After I start the workstation, Opera and Chrome take a lot of seconds (20?) to reach an external website. Firefox brings it up immediately. Somehow I suspect that there might be differences in how these browsers do DNS lookups?)


The problem was caused by an entry in the hosts file which was created by the hostmanager plugin which I used with my VirtualBox / Vagrant setup. (Actually the problem was me, trying to assign app01 to my workstation where it already was (locally) assigned to the VM.)

Because the entry is in the hosts file, I see no DNS lookups. Since I specified the mapped port (8084) in the URL, it tried to connect to a port which is not open on the "actual IP". When I use app01:80 it just works.

Another hint could have been that from another computer, the "app01:8084" works.

So in short: if you don't see DNS lookups, look at the hosts file :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.