3

I have 4k laptop, so DPI scaling is what Windows uses for apps that don't automatically scale.

Rightclicking VirtualBox > Properties > Compatibility > Disable DPI Scaling should do the trick. However, it remains upsampled for guests.

The actual virtualbox management screen looks fine however. (Windows 8 host)

5

Had the same problem with a windows 10 host and an ubuntu guest where suddenly all was a bit pixelated and blurry.

Overriding DPI sampling when right clicking on the exe file and changing the following setting to "application" fixed it.

Would never have found that without your question here. Just posting it if someone else searches for the same problem in the future.

screenshot dpi settings

| improve this answer | |
3

Restarting my host computer fixed it. I guess because the 4k Resolution had been applied and I hadn't restarted yet. Logging off probably could have worked too.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.