0

I'm using a Chromebook with an azerty keyboard. I want it to connect to a Windows server using RDP. I'm using Chrome RDP as it is the only one that I found that actually will connect. However, for some reason, when connected the keyboard settings are never right.

When I set up the Windows server with a US keyboard layout, it actually types azerty for the letters, but the numbers and symbols appear as on a qwerty keyboard. When I set it up as a Belgian (Period) keyboard (what it should be), the opposite happens, letters as if qwerty, but symbols and digits correctly.

Anybody have any idea how to solve this?

1
  • Same problem here with a french keyboard. Moreover I have this issue : When I am in the strange azerty/qwerty mode described by Tom, I hit [Alt Gr]+[0] to get the "@" character and I get a "0" ... and the keyboard switch to qwerty !!! It is definitely related to "Chrome RDP" as everything works fine with rdesktop or the Windows client
    – PhE
    Commented Jun 3, 2015 at 12:13

2 Answers 2

1

There is an option in the general settings of the Chrome RDP client: Untick “Use Scancode input when available” and you'll see that your keyboard layout will greatly improve.

We had the issue with Swiss-French keyboard and un-ticking this option solved it (apart from one key, weirdly).

And it's the same for the Mac Client, from the "Connections" Menu, "Keyboard Mode", select "Unicode" to avoid the buggy scancode mode.

Hope this helps.

0

The Chrome RDP extension doesn't handle correctly keyboard translation .

We found an alternative for having a working RDP solution on a Chromebook that handle keyboard translation (French in our case) : Guacamole. It is a HTML5 remote desktop gateway which uses FreeRDP. You get a full HTML5 RDP client that work well on a Chromebook.

All of our keyboard translation troubles on Chromebook have been fixed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .