0

Read a few related questions here and here.

The situation is as follows: assume that I have a computer A and computer B. I am able to ssh to both computers when by setting Port Trigger and Single Port Forwarding on my router. However, I am not able ssh to computer A from computer B without explicitly setting the Port Forwarding.

Both computers are Linux (Ubuntu 3.13, Kali 3.14), AirLive router.

Is this computer or router problem/misconfiguration? What should be set/configured to solve this?

5
  • Do they have appropriate arp entries? Can you ping? can you telnet/netcat on port 22? – MaQleod Mar 26 '15 at 21:00
  • @MaQleod Unable to ping - Destination Host Unreachable, unable to telnet - No route to host. Not aware of arp entries... The other computer's IP is not in the output. – sitilge Mar 26 '15 at 21:21
  • If they are on the same network (and I assume they are) and you're not arping, then nothing else past that will work properly. So to start, what are their ifconfig outputs? I'd expect them to show IP/mask as being in the same subnet. Open two terminals on each PC, start a tcpdump using something like tcpdump -i <iface_name> -n "host <other_PC_ip> and (icmp or arp)" on each PC and then in the other window on each PC, ping the other PC. Ensure that 1)each PC is sending out an ARP broadcast asking for the other PC's MAC and 2)see if that broadcast hits the other side. – MaQleod Mar 26 '15 at 21:36
  • Pls be more explicit, are both computers on the same network ? – Jorge Aldo Mar 27 '15 at 4:26
  • Yes, the computers are on the same network. The ifconfigs show they have identical bcast and mask. Strange, but arp doesn't find each other, so i suppose this is router problem. – sitilge Mar 27 '15 at 19:12
1

Are the computers behind the router NAT? Are the computers on wifi or wired? Do they have static IPs?

One possible cause might be "client isolation". Most wifi routers support "wireless isolation" or "client isolation" as a form of security feature. This makes all wifi clients that connect to the router not see any other clients on the network. Check that this feature is disabled when testing.

Note: I can't comment on your question or I would have asked the questions there. It helps understand the network you have.

4
  • Thank you, this could be a problem. There was a "Isolation within SSID", I tried enable/disable/restart router but without success. Is there anything similar to this 'cause I think you are on the right track. – sitilge Mar 27 '15 at 19:15
  • Again, not sure what your network looks like. Try to connect the clients to the router by wire and give them static IPs. This way we can narrow the problem down. – Valentin Mar 27 '15 at 23:51
  • What I did try was to connect one of the computers to router by wire and leave one of them using the wireless interface. I was able to arp them and ssh to each other. Whats next? – sitilge Apr 9 '15 at 5:08
  • It does seem like the router has some form of wifi guest isolation. Maybe the router has some other settings you can change? You can also try another router if you have one. – Valentin Apr 11 '15 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.