1

I've been trying to make a dualboot configuration with Linux Mint (17.1 Rebecca) and Windows 8.1. These are the steps I followed in installing this setup:

  1. Install windows 8
  2. Run all available updates
  3. Update to windows 8.1
  4. Install Linux Mint (logical partition for /, /home and swap)
  5. Run into problems with Grub.

When I try installing the bootloader on my primary SSD (/dev/sda) I run into a non working GRUB (after biosscreen only a black screen). When on the other hand I install the bootloader on my secondary HDD (/dev/sdb) and change boot priority to HDD in the bios I get to the GRUB bootloader. From /dev/sdb I am able to boot linux mint without problems, when I choose any of the 3 (3 windows 8 loaders?) windows loaders I run into a black screen again. So I restored the default windows bootloader and I am now able to boot into Linux Mint with HDD as boot prio in bios and boot into windows with SSD as boot prio in my Bios. But I cannot seem to get both working via the GRUB bootloader.

So yeah, wall of text, this is what I tried to fix it so far, at first I was trying to fix the issues with GRUB not showing on my SSD.

  1. Reinstall and update GRUB bootloader via this method.
  2. Moving my windows 1GB from the beginning of the SSD space and making a /boot partition to counter this bug.
  3. Reinstalling Linux Mint several times.
  4. Installing Ubuntu (same issue)

Then I discovered that on /dev/sdb the Grub bootloader seemed to work, so I changed boot prio to my HDD and tried to fix the Windows not loading bug.

  1. Reinstalling GRUB
  2. Updating GRUB (which still gave me 3 bootoptions for Windows 8.1 which I find strange)
  3. Installing Grub customizer on Linux Mint and adding a Windows 8.1 boot option Manually.

Unfortunately none of the above solved my problems, I am running both Windows and Linux Mint in Legacy Mode (so no UEFI or EFI issues). My SSD may have a GPT partition format although I am not completely sure of this. I installed Windows 8.1 before Linux Mint so whatever Windows 8.1 uses as partition method I have.

Hardware Specifications:

  • Crucial M4 256GB Msata SSD.
  • Ordinary 500GB HDD.
  • All in the Lenovo Y500 (i5 edition) Laptop.

Can somebody please help me, as far as I know I tried everything :(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.