3

Long story short, I installed the Windows 10 tech preview on my HTPC. After a recent update to build 10041, I noticed that Windows has started to handle at least some of the commands that are being sent by my remote (a Logitech Harmony One using commands from some generic Windows multimedia remote) in addition to the actions I configured in Event Ghost from before the Windows update.

For the commands that Windows is handling, this essentially causes two keystrokes to be sent to the active window. This isn't terrible, as I can just disable those keys in Event Ghost. However, when I have my remote (or more specifically, Event Ghost) in mouse emulation mode, this causes problems. Every time I hold down a mouse movement button, it also sends the corresponding arrow key. Also, the button I mapped to the left mouse button is the same as what Windows recognizes as the enter key. Whenever I want to left click something, I also hit enter.

I've got Event Ghost set up the way I like it, because Windows was all but incapable of doing what I wanted with the remote by itself. How do I get back to that, where Windows will basically ignore the remote?

2
  • In case anyone was wondering, I also just took a gander through the Windows settings and couldn't find anything relevant.
    – MBraedley
    Mar 28, 2015 at 16:37
  • I guess I should mention that I don't have this problem anymore since installing the full version.
    – MBraedley
    Oct 11, 2015 at 3:41

1 Answer 1

1

The IR remote receiver is being recognized as a keyboard now. You need to remove it from your system's list of keyboards. Open device manager and expand the keyboards section, find the IR receiver-keyboard interface (mine had eHome, which is the name of the driver software Windows uses for my particular receiver), select it and uninstall it. This shouldn't uninstall the receiver drivers entirely, just the keyboard component.

Re-enable all the commands you disabled in Event Ghost, and you should be golden.

1
  • It seems this ins't a permanent solution, as Windows will re-enable the interface every time the computer starts up.
    – MBraedley
    May 4, 2015 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.