0

I've gone through a few questions with the similar issue, but found none with a working solution.

Got a Toshiba laptop for "repair", model "PORTEGE R830-1FT", and I was asked to install Windows on it as it wasn't booting. Specs are i5, 4GB ram, 320gb HDD, with a W7 Pro sticker on the back; no disks provided.

When I try to install either W7/W8/W10 (x64), I get this issue at the disk/partition selection step.

Windows cannot be installed to Disk 0 Partition 1. Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure that the disk's controller is enabled in the computer's BIOS menu. Setup was unable to create a new system partition or locate an existing system partition. See the setup log files for more information.

The hard disk is the laptop's original, a 320GB Toshiba. I tried with another disk, a 60GB one, and with that one it works.

Things to consider:

 - The only disk setting in the BIOS is a performance/compatibility AHCI    mode.
 - Tried formatting the disk and deleting partitions.
 - Tried making a partition on it with my desktop PC.
 - Tried a full disk format.
 - Tried a low-level format.
 - Tried a full disk surface scan, no errors.
 - Tried setting the disk as the 1st boot order.
 - Tried starting the installer from USB and DVD, no difference.
- Trying to install W7 with the disk on my desktop PC: exactly same issue.

Dumping the w7 install files in the root of the disk = no boot.

It's as if the disk is not bootable at all, but there isn't any apparent issue with it when plugged to my desktop.

Any ideas?

enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

11
  • What mode (UEFI or BIOS/CSM) does the laptop boot from? What partitioning type (MBR or GPT) is used on the disk? Does it work if you erase the partition table (and therefore all data) with diskpart from within setup (Shift+F10 for a command prompt) and then re-partition it using the installer?
    – mihi
    Mar 29 '15 at 10:50
  • Also, if not done yet, you may run the disk diagnostics program provided by the disk manufacturer (which probably is not Toshiba as as far as I know they don't make hard disks themselves) just to make sure there are no hidden issues on the hard disk.
    – mihi
    Mar 29 '15 at 10:54
  • Also, some anti-theft options in your BIOS, if enabled, (CompuTrace in particular) can prevent you from booting after a reinstall of your operating system (as the BIOS tries to re-install the CompuTrace agent on the disk and may fail) - check if enabled and if yes try to disable (you may need some unlock code for that). Not sure if setup will detect that, though.
    – mihi
    Mar 29 '15 at 10:59
  • Same results, tried first formatting and creating a partition from diskpart, refresh.. same thing. Deleted partition, refresh, same. The disk is really a Toshiba. I already ran a full disk scan with a couple apps on my desktop, with no errors at all. No anti-theft options in the BIOS that I could see, besides the laptop works fine with another disk.
    – hikari
    Mar 29 '15 at 17:19
  • no, not delete the partition but erase the partition table altogether (I think the command after selecting the disk is "erase" or "clear"). So that when setup creates a partition again it will ask you if you want MBR/GPT or will choose automatically based on boot method.
    – mihi
    Mar 29 '15 at 17:26
1

I also went through good part of what you did, and found that the solution is quite simple:

Leave things in BIOS as default and at the point when Windows installation shows you the partitions, delete them ALL untill there is only one shown as “not allocated,” don’t create any new partition, and click “Next” so Windows will take care of the rest.

0

I battled a similar problem for 3 days. Exact same error: "Ensure that the disk's controller is enabled in the computer's BIOS menu"

My Solution: Go into BIOS > Exit Menu > "Reset the Bios"

Further Details: My system was Asus, Republic of Gamers, with American Megatrends (ami) BIOS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.