0

I'm running Windows 7 Professional, SP1, 64 bit.

I tried to fix what I think is a corrupt regedit.exe file since almost all file associations do not work. Crucially, .exe won't work, and so I want to look into regedit.exe but cannot access it from cmd.exe (which was a heck to get started anyway)

here

As can be seen from the command prompt (when logged in as Administrator)

I tried:

  • assoc .exe=exefile (the error: Permission denied (danish))
  • regedit.exe (the error thrown in danish: No support for this interphase).

How can I get around this?

  • I'd be tempted to go straight for the full malware scan, then restore default perms - see my answer at superuser.com/questions/889980/… for a full-blown work through. – Tetsujin Mar 29 '15 at 15:11
  • 1
    You did not run cmd.exe as administrator. If you did, you would have Administrator: Command prompt in the title-bar. How did you start that command prompt? – Rik Mar 29 '15 at 15:12
  • @Rik, Ctrl+Alt+Del, then pressed Ctrl while started new job. – user3375672 Mar 29 '15 at 15:14
  • @Tetsujin, can this be done without exe executions; it seems like I need to run a lot of programs; that need .exe's (?!) – user3375672 Mar 29 '15 at 15:15
  • 1
    Did you try this fix from microsoft?? It's for restoring the .exe association and is a .msi (so doesn't need .exe assoc.) – Rik Mar 29 '15 at 15:22
0

Perhaps you have a very bad malware on your PC.

Open your Windows explorer, navigate to C:\Windows\system32 and make a copy of regedit.exe, e.g. to regedit_copy.exe.

Are you able to start the Registry Editor with the copied file?

If yes, then navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options and search for any Debugger Key in this sub-tree. Do you find anything?

| improve this answer | |
  • No I could not start it. I got worried of the same (mal-ware, virus). I ended up completely reinstalling windows. Did not wanted to take any chances. – user3375672 Mar 30 '15 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.