After changing my dlink router with a Netgear d6000 I'm no longer able to connect to ftps via filezilla. The settings for ftp connections remained the same but after connecting to the server, Filezilla timeouts after 20 seconds of reading folders(nothing appears in the directory tree). Same problems with different ftps. I don't know if it's router related.

Edit: It's not a timeout issue. Changing the timeout value doesn't change the problem. It blocks when reading folders.

  1. Open Site manager
  2. Click on “New site” button
  3. You need to change the Encryption to “Only use plain FTP (insecure)” and Logon type to Normal
  4. Enter host address, user name and password and click “Connect”
  5. Proceed as per the messages, you may need to enter the passwords again , enter it.

Click here to see the details with screenshots

  • Flagged as not-an-answer, because having a problem with a secure connection, and saying "turn off the security" doesn't fix it. Besides, the server may not accept unsecure FTP connections. – TessellatingHeckler Aug 16 at 0:49
  • @TessellatingHeckler Not an answer should be used for things which are not answers (comments, "I'm having this problem too" etc); it's not a technical judgement of the merits of an answer. You are of course free (and encouraged!) to point out the merits of such an answer in the comments, and propose an alternative using the 'post an answer' button :) – bertieb Aug 16 at 0:54
  • @bertieb "My FTPS doesn't work", "don't use FTPS" really seems like not-an-answer to me, but .. ok if you say so. As soon as I have an alternative which actually is an answer, and I've fixed my own FTPS connection issue, which is how I got here at all, maybe I will post an answer. But it isn't Netgear related, so it likely won't apply. – TessellatingHeckler Aug 16 at 0:56
  • (In addition to the generic advice above, there are cases where I might not worry so much about security, such as connections between two virtual machines on my home LAN; an answer which solves the issue of a timeout while compromising security might be helpful in such an instance, for example) – bertieb Aug 16 at 0:56
  • @TessellatingHeckler it doesn't solve the underlying problem, agreed. It is a workaround, agreed. But frame challenges are acceptable (eg "How can I use the fill command on a photo in MS Paint" "Use a different tool that supports layers" was a recent example off the top of my head); so this is still an answer :) – bertieb Aug 16 at 0:58
  1. Open FileZilla client application on your desktop. A new window will open for FileZilla.

  2. Click Edit on menu bar and select Settings option.

  3. Click Settings and a new small Settings window will open. In the left side of the Settings window there is a subsection called Select page, select the top option called Connection (by default it is selected when you open Settings window if it is not then select it manually). When you click on the connection link you will get an option to set timeout on the right side. In that Timeout section you will get an option to set timeout value from 0-599 seconds. Set this according to your need or you can disable this Timeout settings by settings its value to 0.

  • 1
    These timeout settings in FileZilla server are not related to the timeout problems mentioned in the OT. By default, there is no 20 secs timeout configured in FileZilla, they are all set to 1 or 2 mins by default. Even if I set it to 0, I get the same "20 seconds inactivity" message, so it must be some other limit setting somewhere (I assume outside of FileZilla). – Mathias Conradt Aug 25 '15 at 6:35

I had the same problem when I switched from a D-Link router to a Asus RT-AC68U.

My problems where solved by disabling the NAT Acceleration. This description is for a Asus router but look for NAT Acceleration/Hardware acceleration or something like that, if you have another router.

  1. Login to the router
  2. In the left menu, under Advanced Settings, click the LAN button.
  3. Then click the Switch Control tab.
  4. Set NAT Acceleration to Disable.
  • I get the mentioned error message of 20 seconds inactivity, but only for one certain remote FTP server, not for all. Therefore I assume it should not be related to the router, but to the remote server/network configuration. – Mathias Conradt Aug 25 '15 at 6:36
  • I have the same issue ... if I connect by CLI the FTP looks working (ls retrieve directory ) – Francesco Oct 16 '15 at 11:14

In my case

  1. Click Edit on Menu
  2. Click Settings
  3. Set Time Out to '0'

That's it. It worked in my case. Tried all the above mentioned methods but it wont make any change in my problem.

By just disabling the time out it worked.

This is how I fixed it:

Advanced -> NAT -> RIP CONFIG LIST -> Enable FTP

  1. Open Site manager
  2. Click on “New site” button
  3. You need to change the Encryption to “Only use plain FTP (insecure)” and Logon type to Normal
  4. Enter host address(using ip is better ), user name and password and click “Connect”
  5. Open transfer settings tab
  6. Change transfer mode from default to active
  7. Proceed as per the messages, you may need to enter the passwords again , enter it.
  • 1
    You don't fix a problem with a secure connection by turning of the security(!). And the server may not accept an insecure connection, and certainly 'active' FTP over the internet is very unlikely to work at all. – TessellatingHeckler Aug 16 at 0:50
  • How is this substantively different from Ritabrata Gautam's answer? Most of it is an identical copy. – fixer1234 Aug 16 at 1:38

I know this is an old question, but thought I would post my solution for others who come across this post.

  1. Login to your Netgear D6000 router
  2. Click on the Advanced tab
  3. Click on Setup from the left hand menu
  4. Click on WAN Setup
  5. Tick the check box to Disable Port Scan and DoS Protection
  6. Click on Apply

Screen Shot

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.