I want to install Windows 10 Technical Preview x64 on my computer, and I have downloaded the ISO file.

Now I need to make the USB stick bootable, but I am using Ubuntu 14.04 64-bit (Trusty Tahr), so how can I make a bootable pendrive for Windows 10 from Ubuntu?

I have tried making USB bootable using winusb, but it's not working! Is there another option?

  • askubuntu.com/questions/289559/…
    – smali
    Apr 2 '15 at 10:43
  • 1
    I once answered a question how to install Windows 7/8 without USB/DVD. You may try it. Just use your USB against the partition. Please post the results if it works(works easily for Windows 7/8) for Windows 10 too.
    – Firelord
    Apr 2 '15 at 11:46
  • @Firelord it might work but it's not a good idea to partition the HDD
    – Apurva
    Apr 2 '15 at 11:52
  • That's why I mentioned in my last comment, change the HDD partition location with your USB location. It works for Windows 7/8.
    – Firelord
    Apr 2 '15 at 11:53

I tried dd, but it didn't work. I tried UNetbootin, but it didn't work. I looked for winusb, but I couldn't find it and heard it doesn't work for Windows 10, anyway.

But! This did work for me! http://onetransistor.blogspot.com/2014/09/make-bootable-windows-usb-from-ubuntu.html

Note that I had to add "--force" on the grub-install command.

The steps are basically as follows:

  1. Format a USB drive; give it an NTFS partition. Write down the partition's UUID.
  2. Mount the Windows ISO image and copy all the files to the USB drive.
  3. Run sudo grub-install --force --target=i386-pc --boot-directory="/<path-to-usb>/boot" /dev/sdX, where sdX is like, "sdb". (Not sdb1.)
  4. Put the following text on the USB drive, in a new file at boot/grub/grub.cfg

    menuentry "Start Windows Installation" {
        insmod ntfs
        insmod search_fs_uuid
        insmod chain
        search --no-floppy --fs-uuid <drive_UUID> --set root
        chainloader +1
    menuentry "Boot from the first hard drive" {
        insmod ntfs
        insmod chain
        insmod part_msdos
        set root=(hd1)
        chainloader +1

In the file, replace <drive_UUID> with the partition ID you wrote down. (Note that when I booted it, I saw something like "no such drive U7A6.." or whatever the id I put in was...but it booted anyway, so hey.)

Drive should be bootable at that point. It worked for me. There are a few possible error messages he explains on the site, if you have problems.

  • Thanks for the answer Erhannis; could you edit your answer and summarise the link you've provided please? The content may go stale or disappear. Thanks!
    – bertieb
    Aug 5 '15 at 12:35
  • I did this, however, my pc doesn't boot from usb. It isn't recognizing it as a boot device. I've set the first boot priority as usb...
    – deostroll
    Apr 4 '16 at 4:26

I did that with winusb. To install it, run:

sudo add-apt-repository ppa:colingille/freshlight && \
sudo sh -c "sed -i 's/trusty/saucy/g' /etc/apt/sources.list.d/colingille-freshlight-trusty.list" && \
sudo apt-get update && \
sudo apt-get install winusb

Then I think you can use this program without my help.

You can try UNetbootin. To install, run:

sudo add-apt-repository ppa:gezakovacs/ppa && \
sudo apt-get update && \
sudo apt-get install unetbootin
  • Yeah I found one thread with similar answer, I installed winusb but not sure if it works for windows 10!
    – Apurva
    Apr 2 '15 at 18:48
  • winusb doesn't work for w10
    – Apurva
    Apr 2 '15 at 19:52
  • Try unetbootin sudo add-apt-repository ppa:gezakovacs/ppa && sudo apt-get update && sudo apt-get install unetbootin Apr 2 '15 at 20:16
  • Doesn't work at all. When I reboot, it simply starts Ubuntu, doesn't show me any option to install windows10
    – Apurva
    Apr 3 '15 at 6:56
  • Try to go to bios and change boot priority to your usb. Apr 3 '15 at 7:58

Use the dd command to create a bootable USB stick.

First you must find the device where the USB stick is mounted. If you plug in the USB device and run dmesg you should see the location. An example would be /dev/sdf.

Next you will unmount the device where the USB stick is mounted and write the ISO image directly to the device.

NOTE: Replace the question mark with the USB device device file.

$ sudo umount /dev/sd?
$ sudo dd if=/path/to/windows10.iso of=/dev/sd? bs=1M && sync
  • How can I know my USB device is mounted on /dev/sdb?
    – Apurva
    Apr 2 '15 at 10:41
  • use dmesg command to find mount point of your device files
    – Vengat
    Apr 2 '15 at 10:44
  • 2
    You cant create windows bootable pendrive using dd command
    – smali
    Apr 2 '15 at 10:46
  • askubuntu.com/questions/289559/…
    – smali
    Apr 2 '15 at 10:46
  • @ali786 - first read that article clear you can use dd command
    – Vengat
    Apr 2 '15 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.