18

This is really annoying. Yesterday everything was working fine, now I wake up only to realize that all the videos on YouTube are using the HTML5 player.

Here is what I see when I try to play a video on YouTube: enter image description here

I tried what was suggested by the accepted answer in this question, but it didn't work, even after restarting Firefox.

Also I would like to note that YouTube works fine in Chrome (HTML5 player) and Internet Explorer (flash player).

13

Check if the latest version of Flash is properly installed on your browser. If not, download the latest version and install it.

Then, install the YouTube Flash Player extension:

This add-on forces YouTube to play videos using Flash Player instead of the HTML5 player.

  • this worked like a charm, thank you. Still kind of makes me wonder what went wrong with this HTML5 player,but I will accept your answer. – jsguy Apr 2 '15 at 15:52
  • @jsguy Was the HTML5 player working in Firefox (for YouTube or other sites) before you encountered this issue? – galacticninja Apr 2 '15 at 16:45
  • I am not sure, I never made a check since I was thinking that I was using flash all the time. The first time I heard the term "HTML5 player" was today. – jsguy Apr 2 '15 at 17:25
  • 1
    This worked for me! When i installed firefox i nearly threw the laptop out of the window when youtube didn't work. So i just reinstalled latest version. WORKING :D – 7h3w1z4rd May 30 '16 at 11:48
6

You can force YouTube to play a video with flash player by adding &nohtml5=1 or &nohtml5=True to the URL.

Found this after I had uploaded a video to YouTube and there was "&nohtml5=False" automatically added by any reason.

  • 2
    In May 2016, this suggestions does not work. – Criggie May 26 '16 at 10:06
  • 1
    I can say that &nohtml5=1 works, but true does not. This is an answer and should be treaded like it @Criggie ... +1 from me – 7h3w1z4rd May 30 '16 at 19:18
  • 2
    I can confirm that &nohtml5=1 still works. +1, saved me a bit of frustration. – insaner Jan 23 '17 at 5:58
  • 2
    This is may 2017 and the nohtml5=1 no longer works neither does nohtml5=true work – Mike May 18 '17 at 22:48
  • 1
    I can confirm: nohtml5=1 does not work anymore. – Xan-Kun Clark-Davis May 23 '17 at 11:47
2

Firefox has release MSE support for HTML5 playback. This uses the system hardware decoders unless the driver is blacklisted. Setting media.windows-media-foundation.use-dxva=false in about:config will use software decoding.

protected by Community May 30 '17 at 23:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.