I often work with text files with very long file names, and consequently the tabs are really really wide and thus inconvenient and ugly. How do I make it so that Sublime 3 doesn't display the whole file name, but only a part of it?


Go to:

Preferences -> Settings - User

And add "enable_tab_scrolling": false to your settings file.

Press Ctrl+S and voilà, tabs are displayed as they used to be in sublime 2.

| improve this answer | |
  • 1
    @JasonAller: Congratulations on reaching 2000 rep points.  (I have a sense of déjà vu.) – G-Man Says 'Reinstate Monica' Jun 7 '15 at 23:43

"Enable_tab_scrolling" doesn't resolve the described problem. Honestly, I doesn't understand why another answer have so many upvotes. Nothing personal, but someone could think, that posted answer could actually resolve the problem, while it is not true.

Sorry if I sound rude, it just my lack of language skills.

The answer:

It is currently impossible, even with plugins, as I know. You can rename tab name (to trim it, say, to 20 characters), but this also would rename a filename itself, sadly.

If you want to try it yourself, launch console (Ctrl+`) and then type:

view.set_name("New tab name")

More info could be found here:





| improve this answer | |
  • 1
    You're right in that the other answer doesn't really resolve my problem, but it's better than nothing so I accepted it. What I really want is to be able to set a maximum size of the tabs but still enable it to scroll, which according to you is impossible. Thank you for your answer though. – Ray Apr 8 '17 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.