0

I just recently bought a new ASUS F550J laptop. Here are my specifications:

  • Intel Core i5-4200H 2.8GHz
  • 8GB RAM
  • 240GB SSD
  • Nvidia GeForce GTX 850M 2 GB, GDDR3
  • 1920x1080, FULL HD
  • Windows 8.1

Now my two big issues are:

  1. HDMI is not being detected. I connect my computer to the TV and nothing happens. I have literally tried all the basic Windows+P and all other basic things. I have googled around loads and found not solution. I have even switched to linux, typed in xrandr in the terminal and found that the HDMI seems to be disconnected and of course connected the HDMI cable before testing xrandr.


    Now I wish I know the problem with my HDMI, however I do not. In windows 8.1 it seems as if I also have another INTEL HD Graphics 4600 driver. I think there is something to the fact that I have both INTEL and NVIDIA graphic cards. However I honestly do not know. I am really confused.

  2. Another problem is that whenever I want to play AGE OF EMPIRES 3. It keeps saying that i only have 32 mb graphic card. I run the game anyways and everything works smoothly.

I think my card is not being detected for some reason. Any ideas?

5
  • You need both the Intel and Nvidia drivers installed in order for your laptop to function. So that isn't the problem. Can you provide us the log file for dxdiag by chance?
    – Ramhound
    Apr 3 '15 at 10:56
  • Anything in the BIOS video settings that could be turned off?
    – jdh
    Apr 3 '15 at 11:21
  • pastebin.ca/2967999 HEre is the dxdiag Ramhound. jdh: I cannot seem to find any relevant settings in the bios.
    – Artulo
    Apr 3 '15 at 12:10
  • @Ramhound Sorry forgot to add the @ haha
    – Artulo
    Apr 3 '15 at 17:11
  • @jdh Same with you forgot the @!
    – Artulo
    Apr 3 '15 at 17:11
2

I'm going to walk you through some basic troubleshooting steps to eliminate any possible PEBCAK issues. Please take no offense as I believe they will resolve your problem. To begin, unplug the HDMI cable from your laptop. Verify it is inserted fully into the display you wish to use. If uncertain, hook up another device to make sure it works. Next, in your Windows 8.1 environment, please download and install the following drivers. They are directly from Asus, for your model.

http://dlcdnet.asus.com/pub/ASUS/nb/DriversForWin8.1/VGA/VGA_Intel_SharkBay_Win81_64_VER1018103574.zip?_ga=1.58553193.277065004.1458925176

http://dlcdnet.asus.com/pub/ASUS/nb/DriversForWin8.1/VGA/VGA_nVidia_Verde_Win81_64_VER918133788.zip?_ga=1.58553193.277065004.1458925176

Perform a clean install for the nVidia driver.

After you've installed and restarted the PC, insert the HDMI cable fully into the laptop. Some models feel snug before full contact is made. If you can still clearly see bare metal, it is probably not in all the way. At this time turn on the television and set it to the correct channel for the HDMI port you wish to use.
As you may have guessed, windows + P can be used to quickly extend or duplicate your desktop. Right clicking your desktop and navigating to advanced display properties will bring up all of your possible connection methods. Alternatively, select the NVIDIA Control Panel. If the display port is listed but the display itself is not, I recommend changing the HDMI cable. If a second display is not listed there, you may have an incorrect BIOS value orpossibly a hardware failure. However, based on your DXDiag, I suspect the culprit will be resolved by the above.

EDIT: As you have the same problem in Linux, you can probably skip the driver reinstall and move straight to the cable and channel diagnosis. Make sure that the HDMI cable AND that specific HDMI port on the TV work correctly, and that the TV is on with that channel selected.

You do have both Intel and nVidia graphics, this is a dual-chip design called "Optimus" which uses the Intel integrated graphics primarily for low power and heat operation, while having the nVidia chip to switch to on-the-fly for more power demanding operations, such as gaming. The process is automatic and requires no user interaction, so long as the drivers are properly configured.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.