20

I am on Mac OS X 10.10 (Yosemite) and I am new to Bash. I am trying to install pdfunite. I installed Homebrew and ran the following command:

brew install pdfunite

And I received

Error: No available formula for pdfunite

Searching formulae...

Searching taps...

And indeed after that, if I use pdfunite I get the error “command not found.”

How can I solve this issue?

  • 3
    It’s not part of the brew repository - the utility requires that you install poppler first according to the Github source – njboot Apr 4 '15 at 6:17
27

To have pdfunite working on OSX, you need to install poppler—which is described as “…a PDF rendering library and command line tools used to manipulate PDF files.”—instead:

brew install poppler
2

The procedure seems to work a little differently for me. Here's what I've got and hope it would help:

brew install poppler
gem install pdfunite

Then I double checked to see if pdfunite is installed.

gem search ^pdfunite
## *** REMOTE GEMS ***
## pdfunite (0.3.0)

Initially, I was confused whether to use it over Ruby (irb) or just command line. It turns out that you use it in the command line, which is great. For example, to merge my 2 files in the Downloads folder:

cd ~/Downloads/
pdfunite -h #check how to type the syntax
## Usage: pdfunite [options] <PDF-sourcefile-1>..<PDF-sourcefile-n> <PDF-destfile>
pdfunite file1.pdf file2.pdf compiled.pdf #tab-completion is supported

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.