1

I'm running linux mint 17.1 xfce 64bit and installed calligra suite with this command:

apt install calligra

I didn't use any ppa.

now when I open any application(words,stage,etc) it shows this message :

"Essential application components could not be found. This might be an installation issue. Try restarting, running kbuildsycoca4.exe or reinstalling"

the only exception are kexi and braindump(they open without problems).

I searched and searched not finding any thing related to my problem, I also searched for a way to launch those apps from terminal, I can find calligra command but didn't find any way to open words for example(calligra --help wasn't useful).

Last I tried reinstalling like this:
apt purge calligra apt autoremove apt autoclean apt clean apt update sudo apt-get install calligra but didn't work.

what should I do ?

1

Tell your packager (the linux mint guys) that they should put the proper dependencies in their packages. Obviously some needed dependency is not installed and therefor running the application fails.

You can look withldd <path to binary>if every dynamic loaded library is available. After this useapt-file search <library name>on the missing libraries to find the packages containing them. An other way would be to usingstraceto look which library shall be loaded but isn't.

To see which command is launched when you click the starter of calligra, look into/usr/share/applications/<application>.desktopin theExec=line.

1
  • thanks , I wouldn't solve the problem without you and sorry I didn't accept your answer but that's just because it isn't the "last answer" but it definitly led me the answer – niceman Apr 9 '15 at 14:40
1

Problem solved, I followed this question on askubuntu

that question is for okular but jgomo3's answer and typing apt install kdelibs-bin kdelibs5-data kdelibs5-plugins worked for me.

For future users, if you see a program that is for kde and want it to work on xfce(or others) try the solution I said.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.