This question already has an answer here:

Does Chrome have an equivalent to Firefox's Ctrl+F5 refresh? I can't seem to find one.

I changed my gravatar last night, and I can see the new one in Firefox after a Ctrl+F5 refresh, but Chrome seems to be stubbornly hanging on to the old Gravatar. I guess I could manually clear out the cache, but if there is a keyboard command to do it I'd like to know what it is (since it would be helpful for web development too).

marked as duplicate by Der Hochstapler Mar 19 '14 at 14:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

11 Answers 11

up vote 193 down vote accepted

Chrome documentation states that Ctrl+F5 or Shift+F5 should do "Reloads your current page, ignoring cached content. "

If it is not working, you can file a bug report, but it looks like quite a few other people are having the same issue.

[Existing bug log on this issue] Closed as a duplicate, the issue remmains:

[Issue: 94090]

  • 1
    Looks like it may be partly Gravatar's fault. In the header for my image, they are sending Last-Modified: Fri, 20 Jun 2008 12:25:23 GMT. I think this is either the date I uploaded my old Gravatar, or the date I signed up for Gravatar. The browser must be seeing that and thinking "oh, this new file has the same last-modification date, so I'll just use the cached one still." It's a bug if Chrome is doing that on a refresh ignoring cache, but it's a bug for Gravatar to send the wrong last-modification as well. I've contacted both parties. :) – Kip Dec 31 '09 at 16:16
  • 4
    I load scripts asynchronously from javascript, and Chrome seems to continue to use cached versions even after ctrl-f5, etc. Clearing the cache works. But another solution is to open an Incognito window (ctrl-shift-n), as it will Incognito mode will not use the cache. – Tauren Sep 20 '11 at 7:36
  • 3
    Haha Chrome is super-cached, the only way I can overcome it is hitting Shift + F5 at least two times (really). – Halil Özgür Jun 4 '12 at 10:15
  • 1
    Chrome team should be embarrassed at such a bug sitting in the bug queue for over 2 years. I am very disappointed. – Brian Webster Oct 9 '12 at 10:46
  • 2
    Definitely not working. Chrome can just suck so badly some times. – iconoclast Jun 18 '13 at 17:43

In the opened developer tools (Ctrl+Shft+I or ++I):

  1. Select the Network tab
  2. Activate Disable cache check-box.
  3. DO NOT CLOSE Developer tools - otherwise cache is re-enabled.

enter image description here

  • 24
    +1 I wish I could upvote this more than once. Thank you!! – MrMisterMan Aug 2 '12 at 8:49
  • 4
    But why is there no short-cut key to trigger this! – Coops Nov 12 '12 at 16:32
  • 7
    Note the cache is only disabled while Developer Tools are open. If you close it, your cache is active again. – Icode4food Dec 6 '12 at 16:15
  • 2
    Yes! This should be the accepted answer! This just saved me from never-ending headaches while developing. – ceyko Aug 28 '13 at 16:18
  • 3
    In the newer developer tools (can be triggered by F12, too) the "Disable cache" setting can be found in the Network tab. – anre Apr 27 '16 at 17:35

On a Mac, it's Shift+Command+R, or holding down Shift while clicking the reload button (as opposed to Command+R or a normal click for a regular refresh).

Some more details:

For Shift+Command+R, cache is simply ignored and resources are requested like no cache existed.

For Command+R, Chrome will issue If-Modified-Since or Etag requests to the web server, even for things that are actually cached. For most, if not all, content the server should then respond with 304 Not Modified. This is true for most, if not all, modern browsers.

The only way to force relying on the cache (without the browser even asking for possible changes) seems to be clicking a link on the web page, or by following a bookmarked link, or by going into the URL location bar and hitting Return there (Command+L, Return).

However: a longstanding known issue in Chrome, Chrome Forced Refresh does not ignore cache (and the more recent Reload/Refresh does not refresh), or maybe actually a feature in WebKit, Dynamically inserted subresources aren't revalidated even when the containing document is reloaded, makes Chrome not clear ALL related caches when using the above methods. A Chromium developer explains:

The network tab of the developer tools show a waterfall of all resources as they are loaded. There are two vertical lines at the right hand side... one of them is labeled "Load event fired" on hover. Anything loading after that point is not officially part of the page (a page can keep issuing requests for hours) [...] so it will NOT be "refreshed" with any combination of f5. This is by design.
[...]
Caching [of any resource, before and after the "Load event fired" line] is determined by the HTTP headers of the response, not by the time the request was issued.

Also note a @ChromiumDev's tweet:

Chrome DevTools' Disable Cache invalidates the disk cache (great for developing!), but.. only while devtools is visible.

  • Thanks for the great detailed answer. Possibly too technical for the audience but I value it greatly. – sholsinger Jun 15 '11 at 16:17
  • Command-Shift-R is not working in current Chrome stable. – Olivier Mar 14 '12 at 14:02
  • It seems to be working fine on my Mac, @olouv. Did you peek into the Developer Tool's Network tab? (True, on this very site there are a few resources for which Chrome still issues an If-Modified-Since request instead, but those resources are requested by JavaScript, not by the HTML parser. Also, as caching for the page itself is set to just one minute, maybe small differences in server time and local time might mess up too?) – Arjan Mar 14 '12 at 18:03
  • BEWARE, note a two year old, but still current bug in Chrome: Chrome Forced Refresh does not ignore cache. – Arjan Sep 10 '12 at 17:18
  1. Pull up console
  2. Click in right-bottom to cog icon
  3. Tick [General > Disable cache]
  4. Reload page (however)!
  5. Keep the developer tools open (UPDATE)

  • 14
    5. Keep the developer tools open. – Arjan Apr 1 '13 at 19:55
  • WOW! That's some crucial information! – sobi3ch Apr 3 '13 at 15:12
  • Great, in fact, even after i closed the devtool, it always clear cache. – diyism Sep 3 '14 at 9:34

The question is a bit old, but in the recent version of Chrome

  • Open the Developer tools using F12 or Ctrl+Shift+I
  • Right-click the Refresh button, and select Empty cache and Hard reload

This will bypass the cache and reload the page fully.

The doc says Ctrl+F5 or Shift+F5 but unfortunately as of today the bug is still not solved :-(

  • 1
    As an aside: this is Windows-only. (And I've read it's only available when the developer tools are open?) – Arjan Aug 28 '13 at 17:50
  • 2
    Only works when Developer Tools are open, as you say Arjan. – mgkrebbs Nov 3 '13 at 4:50
  • You can also hold SHIFT while clicking the refresh button – Bolli Jun 24 '14 at 21:11

I have files (images and full html pages) on the server that get updated and no key combination in chrome seems to force fetching them.

I rely on chrome´s incognito mode - CTRL-SHIFT-N - when I need to force refresh.

Note that CTRL-R or CTRL-F5 while inside an incognito window doesn´t seem to work either. You must close and reopen the incognito window - hence my reliance on shortcuts - CTRL-W to close, CTRL-SHIFT-N to reopen.

  • You mean "re-open a incognito tab", not window, I suppose? – mgol Oct 11 '12 at 12:01
  • 1
    Interesting, for me CTRL-SHIFT-N opens a new window, not just a tab - is that not always the case? – Daniel Gill Oct 11 '12 at 18:50

There definitely is no simple way to do this in Chrome like other browsers. The documentation may say that CTRL+F5 or SHIFT+F5 should reload and ignore cache, but it simply doesn't. I have a flash slideshow that stores the settings/configuration in an .xml file, and after updating the XML file, Chrome will still load the cached version unless I purge the cache. I always have to run another browser when updating the slideshow so I don't have to clear my Chrome cache all the time.

  • 5
    Flash cache is something completely different from Chrome. – Joshua Sep 2 '10 at 5:13
  • @Joshua Unless as this guy states, it works in other browsers but not Chrome. Don't forget Chrome comes with its own build of Flash player. – Camilo Martin Jun 28 '12 at 0:14
  • @CamiloMartin ... which also has its own separate cache. Wait... did you seriously respond to a post that's more than 2 years old? Ugh. I took the bait. – Joshua Jun 28 '12 at 14:03
  • @Joshua Oh, you're right, I didn't realise :) – Camilo Martin Jun 30 '12 at 16:03

Ctrl - Shift - Delete will allow you to remove cache for the previous hour. That will assure that the next time you reload a site it is fresh.

Definitely a bug in Chrome - it's also images that should be changed, but it uses the old image instead, even after repeatedly hitting Ctrl + F5.

I was trying to change my Google Apps logo, but the only way it will change on Gmail is if I use incognito mode or clear the entire cache. Ctrl + F5 keeps the old logo.

I did this: Right Click the FRAME (that was out of sync), and SHIFT clicked the "Reload Frame" option. The frame then refreshed properly.

  • Didn't work for me – Coops Nov 12 '12 at 16:31

To clear the explicitly specified application cache navigating to chrome://appcache-internals/ on chrome and removing the cache for specific web sites.

protected by Karan May 28 '13 at 19:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.