Whenever I Click on "Desktop" in windows explorer, I end up with a "hidden" path, such as this:


which makes navigating to the "one up" folder hard (I can enter a folder within desktop, then navigate "two up")

Is there any way I can get it to display like this instead:


(result achieved by navigation from the C drive)

I am not looking for a "manual shortcut", as the built-in "Desktop" shortcut appears in a lot of places and I would much rather have that one function properly instead

  • If you click on the arrow to the right of the word "Desktop", you will get a dropdown. The parent of Desktop is your user folder, usually the one with your name, – Julian Knight Apr 5 '15 at 17:13
  • @JulianKnight - well, that helps a lot, thanks! (still going to leave this open just in case there is a way to get the path there though) – user2813274 Apr 5 '15 at 17:14

This is by design. Desktop is a top-level folder which is why you can't go higher.

But you can navigate to it by typing %USERPROFILE%\Desktop to get the full path. You will not see all files, because Desktop combines both C:\Users\Public\Desktop and C:\Users\%USERNAME%\Desktop.

This is the same as Libraries. They're not actual folders, but are collections of different folders and thus you cannot navigate to a higher folder.

Creating or modifying a shortcut to these locations won't work, as Windows automatically turns it into the Desktop collection. A shortcut to is the best you can do. Question becomes, to where, your desktop, or the public (all users) desktop?

  • Well if I had a choice id choose "my" desktop (I just picked one of the users for a sample..) – user2813274 Apr 6 '15 at 4:01
  • Adding on to the OP's question if I may. What if the folder I am in is myFolder, located in D:\XYZ\myFolder. Can the address bar be customized to show full address? Right now, it shows "Computer" > "NewVolume(D:)" >"XYZ" > "myFolder" – ValarMorghulis Jul 19 '17 at 7:19
  • @George yes that is possible (at least showing it in the title bar all the time (setting), or on command in that location (by clicking next to it)), but given that its solution is different from what I've written here, can you please search SuperUser? I think it already was posted once. If you can't find it, feel free to post a question on your own and you'll get your answer there. – LPChip Jul 19 '17 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.