5

I can copy, move, create, and delete them. I can rename them using the REN command from a command prompt. I cannot rename folders through Windows Explorer anywhere on my machine, including on other drives.

When I try to do so, I receive an error titled "Rename Folder" that says "Can't find the specified file. Make sure you specify the correct path and file name." Then when I click Try Again or Cancel, I get another error titled "Rename" that says "The file or folder does not exist."

As far as I can tell, nothing else is wrong with my computer, but I'm pulling my hair out trying to fix this problem. I don't know for sure if superuser is the right place to ask this question, but feel free to redirect me.

Summary of Failed Attempts:

  1. Booted into Safe Mode
  2. Made a New User Account
  3. System Restore Point (two days ago, 9 days ago)
  4. Deleting / Restoring / Modifying FolderDescriptions registry entries
  5. SFC /scannow
  6. Removing windows update KB2984006
  7. Scanned for viruses using Nod32
  8. Scanned for malware using MalwareBytes

Details:

Tried rolling back to two different system restore points, both immediately before I observed the problem and one release prior to that.

Tried restoring FolderDescriptions registry entries as found here: http://www.reddit.com/r/windows8/comments/1xexqg/cant_rename_a_folder_in_windows_81_any_ideas_my/

Booting in safe mode as suggested here: http://answers.microsoft.com/en-us/windows/forum/windows8_1-files/cant-rename-or-move-folders-in-81/0e2209a2-bb29-4f01-9830-c175de3420f3

SFC /scannow as suggested here: http://www.networksteve.com/windows/topic.php/KB2911106_regression_bug:_Cannot_rename_any_folders_in_Windows_E/?TopicId=61599&Posts=1

Tried removing registry keys and windows update KB2984006 as suggested here: http://www.surfacetablethelp.com/2014/11/cannot-renamemove-folders-and-files-in-windows-8-1.html

Tried exporting folderdescriptions from other machine and importing as suggested here: http://www.eightforums.com/general-support/43167-unable-rename-folders-windows-8-1-a.html

Compared my exported registry with other machine's exported registry for both:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions

My FolderDescriptions branch of the registry in both cases are binary equal to those exported from my wife's Windows 8.1 laptop which works fine.

18
  • Request for clarification: is the issue with all folders, or just particular ones such as those in the Windows folder? Also, have you tried alternate directory tools, such as QDir ( softwareok.com/?seite=Freeware/Q-Dir ), to see if they have the same issue? If they're OK, it might be that Explorer is damaged. – DrMoishe Pippik Apr 5 '15 at 18:54
  • It appears to be with all folders, on any drive location, from any user. Interesting suggestion about alternate directory tools. QDir has no problems renaming folders, so definitely seems Explorer-related. – Alex Pritchard Apr 5 '15 at 20:48
  • 1
    oops... since Explorer is an intrinsic part of Windows, I do not know of any quick fix for the issue; it appears you've tried the most prudent repairs, particularly SFC (as Administrator, I assume). Though you could try reinstalling Windows, that would lose most customization you've done and require a plethora of updates. If defaulting to QDir or alternative file manager is not acceptable, perhaps someone else here can help resolve the issue. – DrMoishe Pippik Apr 6 '15 at 0:38
  • Thanks for the thought! I think for the moment I'm working around it rather than breaking down and reinstalling Windows, partially because I see so many posts of other people who have that problem that eventually just gave up and reinstalled, which means that there is no real fix to be found in their threads! I feel like if I can tough it out and find a solution, maybe someone else can benefit. – Alex Pritchard Apr 6 '15 at 5:38
  • You might get away with a refresh instead of a full reinstall. – Karan Apr 7 '15 at 20:30
2

Alright, after trying everything in this thread and a few additional posts on reddit and MS forums, I finally found something that works.

This Sevenforums - Default File Type Associations tutorial has an entry for Directory - Directory protocol associations which links to this reg file. I ran it then rebooted and now I can rename folders! Here is a pastebin of the reg file if you're paranoid like me and want to glance over it first.

It seems it may have come with some slight side effects, but I'll take it.

4
  • Alas, I must admit that I ultimately ended up upgrading to Windows 10, WHICH STILL DIDN'T FIX THE PROBLEM. So I did a full reinstall from scratch, and that did fix the problem. So, I cannot test your solution, but I'm glad you at least found something that works! – Alex Pritchard Jun 3 '16 at 23:27
  • 1
    Is this solution also available without the side effects? :) – gyozo kudor Jun 9 '16 at 7:31
  • I'm not positive this caused that but I was able to fix it too. – JOATMON Jun 9 '16 at 11:03
  • This just happened to me AGAIN and this time the reg file did not fix it... – JOATMON Jun 22 '16 at 22:03
0

I have three suggestions. Try out and let me know:

  1. Copy the explorer.exe from your wife's computer into yours using a differnt file manager or cmd prompt after ending the explorer.exe process from task manager. This will solve the problem if it occurred because the executable was wonky.
  2. Get the latest possible genuine Windows 8.1 image, mount it in a virtual drive from within Windows itself and choose to upgrade.
  3. Refresh your Windows installation. Follow the instructions from Microsoft here. BE CAREFUL. YOU WILL LOSE INSTALLED APPS AND APPDATA

Once solved, I would suggest either using the default, Microsoft Security Essentials or any other good antivirus with minimal disruptive behavior.

3
  • 1
    I don't think it's a virus. It's almost certainly registry corruption. – JOATMON Jun 2 '16 at 19:26
  • Why would you want to reinstall windows for this? – gyozo kudor Jun 3 '16 at 7:02
  • option 2 won't reinstall, but will probably solve any corruption in Windows files. It keeps all files, settings and softwares option 3 is a kind-of "reinstall" step but it is a drastic one for when you've tried everything but nothing works. – Anish Majumder Jun 5 '16 at 18:32
-1

I just posted on this web site (3rd Sept 2016):

"Windows 10 file explorer won't rename any New folder created" with link below

Windows 10 file explorer won't rename any New folder created

Trying to better document this issue, I found this post link appearing on the right! Brilliant how the links are automatically suggested. I am just amazed by this web site.

So, my W10 issue is very similar to this "old" one. Root cause unknown until know. It is repetitive for me (happened on more than one of my personal PCs after upgrading to W10).

Based on at least three web threads on this very issue, it does not look like a random corruption of the registry but something that happens in a specific setting up context (which one precisely I don't know - I suspect without verification that as a user, I systematically relocate all windows user folders, which may have caused a problem in the upgrade W7->W10)), indeed requiring a registry repair to mitigate.

I guess that W8.1 and W10 deeper testing on it will highlight this problem at some point, which will trigger the production of a fix at MS in due course.

The link above points to the registry keys I & others changed to solve the issue, at least for my config. It has to be tested to see if it also relevant here and can be generalised.

I am still concerned as I don't know what I did & what are the potential side effects. Only it worked. So, I would appreciate input from engineers with knowledge on this just to reassure that this solution is not foolish.

I just saw that someone (w32sh) confirmed firmly - without any deeper insight as to what happened - the more elaborate solution that can be found on http://www.winhelponline.com/blog/error-rename-move-folders-windows-10/

From memory, the solution proposed fully rebuilds (correctly populates) the keys that need to be rebuilt instead of simply deleting 5 keys as I did.

acontrario Brussels

3
  • So what is the solution to the author's problem? – Ramhound Sep 3 '16 at 19:24
  • Please see amended post this time with hyperlink. Sorry for that. – acontrario Sep 5 '16 at 19:17
  • At least this is closer to an answer. If you want to hear more feedback on it, come into the Root Access, when you have enough reputation. – Ramhound Sep 5 '16 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.