1

I'll try to fill in as I can, but here's the basics

  1. We have a VPN (I believe running openvpn) between a site in singapore to a main site in london, with the main site.Its a purely ipv4network.

  2. We have a windows 7 box (in sg) which we use to retrieve a file from a centos 6.5 server running smbd Version 3.6.9-167.el6_5 (in london). Browsing the folder seems workable (few seconds to open a folder) but It takes something like half an hour to start moving a 16mb file, and takes a few hours to download. The issue is replicable with a fresh windows install on our side.

  3. Using a centos box on the same network segment as our system seems to work fine.

  4. Historically there was a Windows xp system doing the same role and it supposedly worked fine. The graphical gnome "connect to server" option works fine as well

  5. We had a period of pretty bad (>300ms latency) between hosts but but currently its sub 200ms and we have the same issue

We've tried forcing the windows 7 box into smb 1 mode to see if it helps.

I don't have the wireshark logs (and am not really at liberty to share them), but I distinctly recall a significant amount of out of order packets when I checked.

How do we work out why its taking so long to initialize a transfer and how can I speed this up? We can't really do much on the UK end, but we can test possible solutions on the singapore/windows side.

0

Turns out that our antivirus was the culprit - We were running avast, and adding the path to exceptions solved the issue. It was still slow tho, but nothing we can do about physics.

I must say, this is the most counterintuitive solution, and I didn't even think of adding the AV as a possible variable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.