33

I installed Ubuntu 14.04 LTS amd64 desktop on VirtualBox 4.3.26 which is running on OSX10.10 (amd64) and the only option for screen resolution is 640x480. This resolution is found under the System Settings -> Displays -> Resolution drop down menu.

I've tried installing the dkms package and virtualbox-guest-additions (which wasn't able to be found, maybe my sources.list file is bad?) as suggested in other forums, but it didn't help.

This is all freshly installed, I haven't tampered with the machine or settings at all.

What is going on here?

3
34

There were two things that were needed: (1) Virtualbox Preferences and (2) Guest Additions for the specific VM.

1) In the top toolbar in OSX, go to VirtualBox -> Preferences -> Display and change your max resolution size. My resolution was set to Automatic and the settings were too low. I changed this to Hint and it allowed me to specify my own Height and Width

2) Start up the VM and log in if necessary. While it's running, click Devices -> Insert Guest Additions CD Image... from the Mac toolbar. There should be some prompts on the VM's terminal then restart the VM when it's completed.

4
  • Does the Guest Additions CD image always need to be attached to the VM or is it a one time install?
    – webworm
    Mar 6 '17 at 18:13
  • Idk why this does nothing for me. Guest Additions is mounted and everything.
    – ucb
    Oct 15 '19 at 17:32
  • 1
    @unami Maybe it didn't install properly. You have to read the output of the Guest Additions install. For instance it might say something to the effect that kernel modules were not installed because the system doesn't have build tools (gcc, make, ...).
    – Kaz
    Jan 22 '20 at 22:21
  • @webworm one time install. Number 2 is the right answer. You'll have to get through the installation process first though.
    – Karuhanga
    May 1 '20 at 22:04
10

I had similar issue with Ubuntu 18.04. Host was Mac OS Catalina and all virtual box's extensions were installed but to solve the issue I've just selected other graphics controller. To do this open settings -> display and try swith to another graphics controller.

screenshot of vbox settings

2
  • 1
    Could you expand on this a little? Your answer is attracting negative attention. Please see How to Answer and take our tour to improve your question.
    – Burgi
    Dec 3 '19 at 9:13
  • This solution worked for me. I am using Mac OS Mojave and running a VM of Ubuntu 16.04 Jan 27 '20 at 5:58
1

I had to do similar to what s g said

So

  1. In the top toolbar in OSX, go to VirtualBox -> Preferences -> Display and change your max resolution size. My resolution was set to Automatic and the settings were too low. I changed this to Hint and it allowed me to specify my own Height and Width

Here I added the numbers from my display resolution so now the linux in VB became as large as the screen. But with very poor resolution.

  1. Then in VB - in linux - I had to set the resolution again to same numbers (it was 1920 x 1080 for me)
0

Have you tried installing guest additions from the menu in VirtualBox? That will mount a CD image and run it's installer

-1

Going into fullscreen mode and then exiting fullscreen mode worked for me. This should make your VM content go as wide as your computer screen whilst still remaining in windowed mode.

1
  • It would have been helpful if you described how to do that.
    – codenoob
    Jul 23 at 1:40
-1

If you still experience problems with setting resolution after setting resolution resizing to 'None' or 'Automatic' in VirtualBox -> Preferences -> Display and mounting GuestAdditions execute following command in guest's terminal:

sudo apt-get install --reinstall linux-image-$(uname -r)

Then perform a reboot

It worked for me - guest was Ubuntu 18.04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.