6

I'd like to remove the "on behalf of" from my emails in Outlook 2010. It appears when I use the from drop down while sending an email:

enter image description here

When I send an email from the address the outlook profile was created with, it will appear as this:

Name

however when I use the from option, it will appear as this:

Name < [email protected] > on behalf of [email protected]

Often I use this other email adress(s) to hide my main one to protect from spammers (I dispose of the address after the fact), but this foils the plan.

My research shows that most people create multiple outlook profiles, but in my case that would require too many profiles and too much work. I just wan't to remove this part of the header, without complicating my setup:

Name < [email protected] > on behalf of [email protected]

This is not a duplicate of this: Hide email adress of sender when sending on behalf of, the accepted answer won't work here, and the question is much much vaguer then this one.

12
  • That is much better! I will remove my comments to reduce clutter in the comments.
    – CharlieRB
    Apr 7, 2015 at 15:58
  • This article points to an add-in to Outlook that supposedly solves the problem.
    – harrymc
    Apr 9, 2015 at 11:26
  • @harrymc It still give the email in the header :/ Apr 9, 2015 at 15:01
  • According to a comment on the article : "you have to install the Microsoft Visual Studio 2010 Tools for Office Runtime. Once I installed that then the add-on worked."
    – harrymc
    Apr 10, 2015 at 20:07
  • I'm not sure this is related to what you're asking for, but it might be worth checking out (if you use Gmail with Outlook): gmailblog.blogspot.in/2009/07/…
    – Vinayak
    Apr 10, 2015 at 20:21

3 Answers 3

1
+50

Outlook adds the On Behalf Of header to the message in order to protect it from being branded as spam by some ISPs or email clients.

Unfortunately, it seems as though turning this mechanism off is only possible when using Exchange server or Active Directory.

The article Send On Behalf and Send As shows three ways of enabling On Behalf Of using Exchange.

The article How to grant Send On Behalf Of permission also add how to grant On Behalf Of via Active Directory.

However, there does not seem any method in stand-alone Outlook to avoid the On Behalf Of header being automatically sent. If that header is a problem, perhaps using another email client such as Thunderbird, or Gmail, will solve it.

1
  • You can have the bounty, I see no point in having it go to waste, and you where helpful. Apr 15, 2015 at 13:06
0

I developed an add-on for solving this issue and does not require Microsoft Exchange. The article and the application is available here.

0

First in Gmail add your non Gmail account on settings under "send mail as:" Gmail

Then in Outlook on Account Settings change the email address: Outlook 2016 Now, because Outlook uses Gmail SMPT other than your non-gmail provider, it doesn't add the "On behalf of" to the header.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .