The download speeds while connected on Wi-Fi to the same router—an ADSL2+ Wireless N300 Modem Router—seems to be significantly faster on my phone than on my laptop. This problem doesn’t occur all the time, but the Internet connection on my laptop—which is running Ubuntu 14.10—occasionally reduces in speed and becomes unstable, while the Internet connection on my phone remains at the same speed and is continuously stable.

As a comparison, I performed a test on speedtest.com at the same time and the same location for my laptop and my phone during an “unstable connection phase” for my laptop.

I was wondering what potential causes there could be for this discrepancy?

Here are the speedtest results from my laptop (Lenovo Y50 UHD):

enter image description here

And here are the speedtest results from my phone (Samsung Galaxy S5):

enter image description here

Note that while the Samsung Galaxy S5 has a “Download Booster” feature which can use your Wi-Fi and mobile network simultaneously to increase download speed, for this test I turned off the mobile data completely on the Samsung Galaxy S5 but I still received similar results comparing my laptop and phone.

  • Can you please edit your question: You are providing some decent details on your phone and laptop, but what is the exact make and model of the Wi-Fi router you are using? The laptop seems to use an Intel® Dual Band Wireless-AC 3160. – Giacomo1968 Apr 7 '15 at 3:19
  • If you haven't already updated wireless drivers, I would suggest you do. There was a know issue with wifi performance for this laptop (and a few others from Lenovo). Let us know how you go. – Papa Apr 7 '15 at 3:33
  • @Papa: I believe all my wireless drivers for the Intel Corporation Wireless 3160 are updated, and I'm currently running Ubuntu 14.10. – amy Apr 7 '15 at 3:47
  • Probably not the cause, but for elimination purposes, have you checked that the "unstable connection phases" aren't the result of other network activity running in the background (if, for instance, Ubuntu had something like Windows Updates) – TripeHound Apr 8 '15 at 10:16

I believe this boils down to what is—very sadly—a common wireless headache: 802.11n Wi-Fi implementation is so horrible and inconsistent between devices that the 802.11n protocol becomes fairly useless. This PC World magazine article titled, “Wireless Routers: The Truth About Superfast Draft-N” summarizes the headaches quite well; bold emphasis is mine:

We also found that routers based on different draft-n chips (the Belkin uses Atheros chips, while the other three are based on Broadcom chips) do not interoperate at high speed. Buying products from the same vendor doesn't always ensure that all of them will use the same draft-n chips, either: At least one company, Netgear, is selling similarly named routers and PC Cards that are based on different draft-n chips, and you can determine which chip a product uses only by checking its model number and/or the chip logo on its packaging.

Especially this assessment of the overall murkiness of the 802.11n world of hardware and how manufacturers are essentially using end users as “alpha” and “beta” testers:

But we'd rather vendors didn't use paying customers to do their alpha and beta testing. You shouldn't have to install multiple firmware updates to see promised performance on a brand-new product.

To better understand how this kind of stuff plays out in a real-world situation—like yours—let’s look at all of the supported wireless protocols of your devices:

Okay, that might seem like an impenetrable wall of specs, but the key spec is your router which seems to only be able to only use the maximum 802.11 protocol of 802.11n (draft 2.0). I am no 100% expert on the headaches of 802.11n specs, but I do know that the 802.11n “draft” specifications are fairly ancient and any modern device worth anything should be using an 802.11n “final” spec.

That said, knowing that alone won’t help you much in theory or concept. In practical terms there are only three solutions I can provide that I think will work.

  1. Buy a New Router: Since you are using an ADSL modem/router combo, I would recommend getting a separate router that supports 802.11n “final” at least—802.11ac at most—and using that router instead. You would then be “neutering” the router ADSL2+ Wireless N300 Modem Router to use it in “bridge mode” and connect that to the new router and things should be tons better.
  2. Adjust Your Laptop Settings for Better 802.11n Performance: Again, not 100% on the whole world of 802.11n tweaking, but if there is any way for you to adjust settings to lock your laptop at specific specs/speeds I would recommend that. The most obvious thing that comes to mind is forcing the laptop to use 802.11n at 2.4Ghz instead of 5Ghz and if there is a “mixed” mode—meaning it would downgrade to 802.11g or 802.11b if needed—then disable that and force one protocol to be your preferred protocol.

    I would even recommend testing this theory out on the slower 802.11g protocol and to see if that helps in any way. Then move up to 802.11n and tweak that to see if you can successfully tweak 802.11n settings to work best for you. Heck, if running at 802.11g protocol works better then maybe you should stick to that since the max speed of 802.11g is 54mbps which would only be slow between devices on your LAN but more than 5x adequate for your WAN connection which seems to max out at around 10mbps anyway.
  3. Adjust Your Router Settings for Better 802.11n Performance: If you can, see if you can lock your Wi-Fi router in at one Wi-Fi protocol setting. Similar to what I outline in idea 2, but the difference here is your router settings might affect your portable device settings as well.

And all that said, if this were the headache I was dealing with, I would do as I outline in idea 1 and just spring for a new Wi-Fi router. Typically an ISP provided combo modem/router is just lacking in features and updates as well as lacking in support from a larger world of users. By purchasing a new router you not only solve your issue quickly, but you will instantly be able to tap other users of that more commonly used router for advice and tips if new issues come up.

  • But if the problem was the router, wouldn't the phone be slow as well? – A G Apr 7 '15 at 13:56
  • 10
    @AG Nope. That is what I am touching on. 802.11n implementation is so inconsistent that the phone could simply be better able to handle 802.11n better than the laptop. Frankly you can go nuts attempting to debug 802.11n issues like this because of inconsistencies like that. The reason I focus on the router is because ultimately for less than $50 a new router will be more up to date and reliable than a modem/router combo that has out of date Wi-Fi connectivity options. – Giacomo1968 Apr 7 '15 at 14:15
  • 1
    @AG Not if the router's problem is that it implements the 802.11n spec inconsistently, so that it handles some clients well and other clients poorly. If so, it could well be that the phone is "lucky" (or has extra steps to work around these foibles) and avoids the issues, while the laptop is subject to the degraded performance. – Andrzej Doyle Apr 7 '15 at 14:15

For your specific situation where you use an Intel network card on Ubuntu 14.10 (which has a kernel newer than 3.13), a change in the iwlwifi driver can possibly have affected the throughput of your Intel wireless network card.

This change can be be reverted by creating the file /etc/modprobe.d/iwlwifi.conf containing:

options iwlwifi 11n_disable=8

To test it, reload (unload and load) your Intel wireless modules with modprobe commands:

$ sudo modprobe -v -r iwldvm
rmmod iwldvm
rmmod iwlwifi
rmmod mac80211
rmmod cfg80211
$ sudo modprobe -v iwlwifi
insmod /lib/modules/3.16.0-33-generic/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/3.16.0-33-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko 11n_disable=8
insmod /lib/modules/3.16.0-33-generic/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/3.16.0-33-generic/kernel/drivers/net/wireless/iwlwifi/dvm/iwldvm.ko

You can also verify the parameter by reading a file in sysfs:

$ cat /sys/module/iwlwifi/parameters/11n_disable 

This change improved by LAN throughput from 20 Mbit/s to 80 Mbit/s.

  • 1
    Apparently, "11n_disable=8" enables antenna aggregation. – Yorik Apr 7 '15 at 19:45
  • @Yorik Correct. Initially only 11n_disable=1 was supported (as boolean), but later more states were needed. The full description from modprobe -p iwlwifi is: 11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint) – Lekensteyn Apr 7 '15 at 21:43
  • 2
    it's 'modinfo -p', not modprobe, for folks like me playing along at home – Rob Latham Apr 8 '15 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.