0

I am basically attempted to share my wired LAN connection on my Laptop to my Phone. Even if I cannot share the connection but can just connect from my phone to the Laptop it would do for me. I have a Windows 7 Laptop and a phone running Android 4.2.2 (Jelly Bean). When I run

netsh wlan show drivers

I see the Intel(R) WiFi Link 5300 AGN driver with the date 1/19/2011 and most importantly I see:

Hosted network supported : Yes

which I assume means that I can run a Hosted Network. I then followed the instructions given here: https://superuser.com/a/444782 I also ensured that the Internet Connection Sharing Service is started on Windows 7. My phone can connect to other WiFi networks and ping their gateways.

Problem: I seem to be able to connect from my Android phone to the Hosted Network on Windows 7 Laptop, but I cannot do anything else like ping it.

I cannot ping from Windows to Android nor in the reverse. When I run:

netsh wlan show hostednetwork

on Windows, I can see the Number of clients connected. When my phone connects or disconnects I can see it here. However, I cannot ping either way, and from my phone I cannot connect to the Internet.

Any ideas on what I should try?

Additional Information: The Windows firewall is completely off on the Windows Laptop. I have Microsoft Security Essentials and no other Anti-virus as far as I know.

  • Hace you tried turning off any firewall software you have? I'm not sure if ICS will configure non-windows firewalls for you. – Devan Apr 7 '15 at 22:11
  • Thank you Devan I have turned off my Windows firewall completely for all domains. – O.O. Apr 8 '15 at 16:38
  • Please do not post the solution in the question itself. Instead, post the solution you found as an answer (yes, you may answer your own question). – Excellll Apr 17 '15 at 21:02
0

As requested by Excellll, I'm posting my answer here. This may have been a problem that is particular to me, but I'm hoping it may help others.

I have since noticed something was wrong in my Event Log i.e. my System Log I had an event from Source: NETwNs64 which read something like:

The description for Event ID 5010 from source NETwNs64 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

\Device\NDMP12 Intel(R) WiFi Link 5300 AGN

The specified resource type cannot be found in the image file

The Solution: Completely uninstall the Intel WiFi Driver, and reinstall it again.

I found this strange, because I could connect from my phone to my Laptop, but I just could not ping. Also I had no problems connecting to regular WiFi routers, so I did not expect something was wrong with my driver!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.