2

I am experiencing consistently slow login times on my Windows 8.1 machine. I have a PIN set up, and after I enter my PIN it takes about 20 or 30 seconds (not sure) for the "Welcome" message with the spinner to appear. Most of the time the lock screen even comes back (it goes away when the Welcome message appears).

Any suggestions?

9
  • This sounds like you should replace your system drive, what you describe, can be explained by Windows spending a bunch of time trying to handle I/O events.
    – Ramhound
    Apr 7, 2015 at 23:12
  • I agree, Replace the HDD with a SSD. And also have a look at your startup programs and disable ALL except the AV program (in the Task Manager)
    – whs
    Apr 8, 2015 at 0:06
  • capture a boot trace and share the trace: pastebin.com/CYGqRZXE Apr 8, 2015 at 4:33
  • 1
    I have the exact same issue lately. It just started happening a few days ago. I do have a SSD and it used to be almost instantly before.
    – b3n
    Apr 17, 2015 at 22:09
  • @b3n also share a boot trace. Apr 18, 2015 at 5:29

5 Answers 5

1

For Windows 8.1 and using a pin, if the Credential Manager service is set to manual it might be part or all of the problem. Set Credential Manager to Automatic, reboot and try using the pin again.

1
  • You are absolutely CORRECT, I can't thank you enough! I don't have Teamviewer so that's wasn't the reason, your fix worked instantly and login is blazing fast again.. thanks again!
    – andreszs
    Jan 20, 2021 at 23:27
0
  1. Be sure you have Windows 8 fast startup enabled; it's also known as hybrid boot.

  2. Use Sleep for almost immediate startup; for laptops, enable Hibernate after a while in Sleep when on battery power This is set with the Power Options | Change advanced power settings dialog.

0

Apparently, TeamViewer was the one causing the problem. (See the question comments)

1
  • In my case it was the Credential Manager service set to Manual, as user Tim accurately pointed out in his reply.
    – andreszs
    Jan 20, 2021 at 23:28
0

Another solution would be to disable the Origin Services, like mentioned on this youtube video (https://www.youtube.com/watch?v=DTUhx4GPOVQ) comment by @Jasaiku:

11/12/2016 For me, the problem was the Origin Client Services and Origin Web Helper Services, I disabled them in services.msc.

-1

This may sound a bit nuts but I one day disabled a whole lot of services (superfetch, windows search, and a lot of other ones I perceived as pointless) to keep my speedy hot-rodded and overclocked HP EliteBook 8760w running at top speed, but then one day logging in was awful slow. I do have a 7200rpm hdd that was nice and speedy ( ~ 120 MB\s) when I first installed and I defrag a lot. so I looked in services.msc and found the Microsoft keyboard filter service. I re enabled it and now login is almost instant again! also make sure that credential manager service startup type is set to AUTOMATIC, not manual!

PS!!! You don't need to waste money on a SSD! just reinstall windows and shortstroke the hard drive, or figure out the service or driver causing the problem, and avoid installing any crapware that runs at boot, and manualy install drivers, especially the graphics driver!

BTW my specs are HP EliteBook 8760w, 8-core :) Intel 2nd gen Core-i7 2.9 GHZ, NVIDIA Quadro 5010M GPU 4GB Graphics RAM, WD Scorpio black HDD 7.2K rpm

4
  • Reinstall to avoid upgrading hardware?!?! Oh my, what year is it? 2003?
    – Bruno9779
    Apr 19, 2018 at 20:21
  • im just waiting for an ssd that supports hibernation FYI so I can get two of them and put them in raid on my TWO internal sata ports in my pc. BTW windows 10 sucks Apr 19, 2018 at 23:29
  • USE WINDOWS PERFORMANCE ANALYZER AND XPERF! Apr 19, 2018 at 23:30
  • Can't you just make your SSD your boot drive?
    – sean
    Jan 21, 2021 at 0:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .