2

I'm about to get back into java programming, so I downloaded the latest version of Java, Java 8 update 40.

Now, my MacBook has seen better days, and who knows how many version of Java is in it. At first everything went fine, with java -version giving me the right one (1.8).

Then I tried running Spring Tool Suite, which was pointing to the wrong jvm, that of 7, and jvm 8 isn't listed anywhere.

After trying out a lot of ln's, a lot of rm's, etc., etc, I tried to install Java for OSx 2014-001.

Worst mistake so far, so I tried re-installing jre-8u40-macosx-x64.dmg.

Didn't help one bit. Now even java -version reads:

java version "1.7.0_71"  
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)  
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

While /usr/libexec/java_home -V says:

Matching Java Virtual Machines (3):
    1.7.0_71, x86_64:   "Java SE 7" /Library/Java/JavaVirtualMachines/jdk1.7.0_71.jdk/Contents/Home
    1.6.0_65-b14-466.1, x86_64: "Java SE 6" /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
    1.6.0_65-b14-466.1, i386:   "Java SE 6" /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

All while the Java control panel displays:

enter image description here

So, which screw do I hammer in with my wrench this time?

  • is apple.stackexchange.com/questions/143717/… any use ? – Tetsujin Apr 8 '15 at 10:14
  • @Tetsujin, unfortunately, no. My .bash_profile contains nothing but a php line, /Library/Java/JavaVirtualMachines/ has nothing but jdk1.7.0_71.jdk, typing in /usr/libexec/java_home -v 1.8 returns Unable to find any JVMs matching version "1.8". /Library/Java/JavaVirtualMachines/jdk1.7.0_71.jdk/Contents/Home. – zack_falcon Apr 8 '15 at 10:26
  • Install the JDK rather than the JRE to get full Java 8 on OS X – greg-449 Apr 9 '15 at 10:36
8

You need to install the JDK rather than just the JRE to get full Java support on OS X.

The official Oracle download site is http://www.oracle.com/technetwork/java/javase/downloads/index.html Click on 'Java Platform (JDK)' and download 'Mac OS X x64'

  • It would be helpful if you could add a link to where to get it. Thanks. – fixer1234 Apr 10 '15 at 7:11
  • @fixer1234 Added download location – greg-449 Apr 10 '15 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.