6

The Problem

I built a new computer this week and installed NixOS on it. The only problem that I am having with it is that I cannot seem to get the Nvidia drivers installed for it.

The computer has a Geforce 970. The only way I have been able to get the displayManager running is by leaving the videoDrivers configuration as the default. By that, I mean that I have tried adding "nvidia" and "nouveau" to the list, but after a reboot I only have access to the shell with either of those in the list.

More Details

The result of running

lspci | grep VGA

is

01:00.0 VGA compatible controller: NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1)

Running xrandr shows

Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
    1024x768      61.00* 
    800x600       61.00  
    640x480       60.00  

Of course, I'm expecting something besides a 'default' output, and 1920x1080 for the resolution.

xrandr --listproviders

Providers: number : 0

and my personal favorite, running

glxinfo | grep -i vendor

shows

server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: VMware, Inc.

What is really surprising to me is the VMware vendor string in glxinfo. To be totally honest, most of my linux experience is with ubuntu, mint and fedora, and I've never had any 'real' driver problems, so this is all pretty new to me. Any ideas?

3

try adding the following to the /etc/nixos/configuration.nix

nixpkgs.config.allowUnfree = true;
services.xserver.desktopManager.kde4.enable = true;
services.xserver.videoDrivers = [ "nvidia" ];
hardware.opengl.driSupport32Bit = true;

Then run:

nixos-rebuild switch

Anyway, I've got a GeForce 9500, and this worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.