2

I have Arch Linux (64-bit) and I installed 32-bit Windows 10 in VirtualBox. Everything seems to work fine—fullscreen, scaled, etc…—except for seamless mode. When I activate seamless mode, the virtual machine disappears. It continues to run, but it just disappears. How can I fix this?

(And, yes, I have guest additions installed.)

It looks like this:

enter image description here

  • Isn't that what seamless mode does? I guess, what are you expecting to have happen? – heavyd Apr 8 '15 at 23:15
  • Well, I am expecting a fullscreen 1920x1080 windows desktop, but it looks like there is just a chunk of a corner and a windows taskbar at the bottom that disappears when I click it – user435819 Apr 8 '15 at 23:35
  • Seamless mode just does not work yet virtualbox.org/ticket/15092 – Gabriel Schanuel Jun 12 '17 at 17:52
  • Google brought me here. I'm running an Ubuntu guest on a Windows 10 host. I'm expecting to see the normal Windows screen, with the Ubuntu toolbar/dock as well as the "Activities" bar with the date, shut-off options, etc. When I switch to seamless, anything but guest windows I had open disappears. That means I can't start any new programs in seamless mode. – bballdave025 Dec 10 '18 at 19:10
3

There is a known Virtualbox bug for this behavior which is nearly 2 years since it was reported.

If you want to fix it, I guess you would need to submit a pull requets with a fix to Virtualbox's team... or sadly, wait longer :/

1

Virtualbox's Seamless Mode doesn't show a seamless desktop. If you have any applications running on your VM, seamless mode makes the VM desktop disappear and puts the VM applications on your desktop, so you can use, for example, Google Chrome for Windows on a Linux desktop. See here for more information.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.