2

I have the PDF "GNU Image Manipulation Program: User Manual" downloaded to both my Windows PC, and my iMac OS X v.10.9.5.

The search function works perfectly in my PC, using Adobe Reader, but it doesn't work at all in my Mac, using neither Preview, nor Firefox browser. Not even my newly-acquired (in a desperate attempt at the end of a long frustrating day of troubleshooting as best i know how!) Skim PDF reader!

I tried re-downloading the PDF file to my Mac, still no luck. Then, I thought, maybe it's the reader; perhaps there's some quirk in this "GNU" PDF, that makes most readers unable to recognize all its text as a fully searchable component? (And maybe Adobe Reader is extra powerful in that regard?)

(I tried then double-checking, to be sure that i could use the search function on my Mac in other PDFs, and yes I can! I searched through every one I tried perfectly, and I tried several, — all except this "GNU" PDF work fine!

Unfortunately, when I searched online for an Adobe Reader download for my Mac, it seems that it does not exist for Mac!

Maybe the reason I couldn't make at least my Firefox search in this "GNU" PDF in my MAC, is due to the add-on which i have only for Windows not for Mac: Adobe Acrobat 11.0.8.4 PDF Plug-In For Firefox 11.0.8. It seemed perhaps a more functional app than Preview, or than the app I now have in Firefox on MAC, which is the built-in Firefox PDF viewer('Free Foxit Reader').

But, alas, my search for that Adobe Acrobat add-on showed it also unavailable for Macs.

One thing I did find, though this might be just out of my desperation to find anything at all that might be do-able (since this "GNU" PDF is crucial for me, as I depend upon the GIMP program it pertains to and have had no success in installing the contextual help itself and without being able to search this PDF, I am hopelessly lost!)

It's this link: http://www.macupdate.com/app/mac/73/adobe-reader (= Adobe Reader for Mac- Mac Update) = at http://creative.adobe.com/ .

But it seems to me to be probably only an "update" to something that maybe was available at one time, as i cannot find an actual Adobe Reader app for Mac?

Does anyone have any ideas? What have i not tried or what am I not understanding?

1

I've never experienced anything like you described. Try downloading Adobe Reader here. If the Search doesn't work with Adobe or Skim (my preferred choice), I would question whether your PDF file has been created / encoded correctly.

Given that Adobe invented the PDF standard, I would think Adobe Reader is the de-factor standard in displaying / rendering PDF files - check if you can open the same file on PC using Adobe there.

0

I would guess that your Spotlight is not indexing PDF files for some reason. You can check this by opening System Preferences > Spotlight, and ensuring that "PDF Documents" is checked. More info at #3 here: https://www.alfredapp.com/help/troubleshooting/indexing/

  • Thanks everyone! Brian Duddy, i read the linked article you gave here, but i have no idea about "Alfred". I have never heard of that before. And the info there talks about searching for files, not for text within a file. (?) – Z Ixazaluoh Jan 8 '18 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.