2

I want to add a network printer as a shared printer. I am following the following instructions:

  1. Click Start > Devices and Printers.
  2. Click Add a Printer on the top.
  3. Select Add a local printer.
  4. Select Create a new port, select Local Port for the Port Type, and click Next.
  5. For Port Name, enter the network path to the printer by entering two slashes, the computer name or local IP address of the PC sharing the printer, and then the share name of the printer. For example “\\dellpc\hpprinter” or “\\192.168.1.100\hpprinter
  6. Select the printer and click Next. If the exact model isn’t listed, try the closest model number or a generic printer.
  7. Follow the rest of the wizard.

I am getting stuck on step 5. I enter the name of my printer as \\10.1.11.43\Color Konica Minolta and get the error "The specified network name is no longer available". The network location comes right out of the printer properties (Ports tab) and is a valid working printer.

  • Hi Tyler, is the printer being shared from another computer or is it directly connected to the network? What is the model of the printer? And when you say add as a shared printer, do you mean you want to add it so you can use it, or add it so you can share it from your PC? – Louis Apr 9 '15 at 22:29
  • I think it is pure networked printer, just plugged into the LAN, not connected to a server/computer. I want to add it as a Local printer which is what the listed steps are supposed to do. Some older software only works with local printers and does not have the capability to connect to network printers. – Tyler Durden Apr 10 '15 at 0:01
  • 1
    A printer is either local (attached to your computer), or networked. To be local, it has to be attached to your computer. If you do that, you can share it and other computers on the network could see it if your computer is on. You can access a network printer, but you can't make it local, which is why the add-a-printer dialog isn't working. If you add the information about the old software to your question, there might be a solution to get it to see a network printer. – fixer1234 Apr 10 '15 at 0:08
  • 1
    In that case, we should first try using the just IP (or hostname), and port if you know it. In the Add Printer screen, choose the TCP/IP option instead: i.stack.imgur.com/XY94l.png – Louis Apr 10 '15 at 0:55
  • This is totally between you and your IT people, but be forewarned that adding a network printer as a local printer completely bypasses your IT's print server. The IT people at the company I worked for said doing this can crash your local network, depending on how much traffic goes to that local printer. I'm not sure if that's true (I never tested it), but it sounded reasonable. – BillDOe Apr 10 '15 at 20:48
2

I have solved the problem by creating a TCP/IP port. Although the steps in the question do work on a generic system, our LAN has group policies preventing named access to a printer in the way specified.

An alternative way which does work, as the commenter "Louis" said, is to use a TCP/IP port. So the correct steps are:

  1. Select "Create a New Port" and choose "Standard TCP/IP Port"

  2. Enter the IP address of the printer. (The IP address of your printer can be determined by right clicking on your printer in the Devices control panel and selecting "Printer Properties" and the tab "Ports".)

  3. Select a driver from the ones offered. (If you are sending data directly to the printer like me, then the driver is irrelevant because it gets bypassed anyway.)

  4. Follow the rest of the wizard which gives you the option to set the added printer as the default printer.

You can then verify that the printer has been added locally by using the command:

wmic printer get caption,name,deviceid,drivername,portname

The local printers will be listed first in the resulting list.

protected by Community Sep 20 '18 at 6:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.