2

After reformatting my USB-stick it became unreadable by Android filesystem. Android Supports only NTFS or FAT32, but whenever I try to format USB-drive from Ubuntu to any of the types I can see flag "msftdata" in GParted. I believe this is the problem. Windows and Ubuntu can read it fine though. Ubuntu filesystem seems to struggle to determine USB-stick's filesystem, but can read it. I tried to reformat into different types, change flags, but no success so far.

UPDI was able to read USB-stick using StickMount app from Play Store. I would still prefer Android to mount it though.

0

You can simply wipe first 1 MB of your USB stick:

dd if=/dev/zero of=/dev/sdb bs=1M count=1

and then reformat it to FAT32 again.

Be careful though: make sure that /dev/sdb is really your flash drive, or you will kill contents of your real hard drive!

  • I'm not sure which partition table I should create. I tried "gpt" but no luck with android reading it. – iamart Apr 11 '15 at 18:30
  • Use msdos partition table. Almost nothing supports gpt on flash drives (Linux does). – mvp Apr 11 '15 at 18:35
  • for some weird reason it is still unreadable on android. No idea what can be preventing it from reading. – iamart Apr 11 '15 at 18:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.