Back Story: I downloaded OuterWilds and the download failed to complete, being incompetent but also tech savvy, i got the "OuterWilds_Alpha_1_2_PC.zip.part" file, renamed it to "OuterWilds_Alpha_1_2_PC.zip". In an attempt to re download the program, from where it left off. however as you know, this turned the file type to a zip. So i tried to convert the file back into a "Windows shell common dll", this was the default file type association, which from my research uses the shell32.dll. Doing research online, it said, right click file >> Open with >> Select Default. Then i pressed browse as shell32.dll isn't listed, i then changed the search filter from "programs" to "all files (".")", navigated to the Shell32.dll path which i believe is somewhere in "C:\Windows\Systen32". I selected the shell32.dll file. Unknown to me, i didn't pay attention, i accidentally set this to be the default file association for all .zip files -_- I'm so stupid.

My Attempts To Fix It:
-----Attempt 1
Start >> All Programs >> Default Programs >> "Associate A File Type Or Protocol With A Program". Went to .zip and changed it from "Shell32.dll" to "Windows Explorer", which i believe is the default value and then the .zip disappeard and below is the result. Image: http://imageshack.com/a/img901/2865/fBMz2z.png

-----Attempt 2 Reading online, it suggested using cmd prompt as admin to reset it to default, I can't find the webpage but i think i entered in a command similar to: "Assoc .zip=CompressedZipFolder", whatever the command, it seemed to be correct as the DOS window didn't throw any errors. When i type "Assoc" in the shell, i get a list of all file associations and .zip is there, however when i go back to the GUI listing of file associations, it is still the same as the image above. Refer to Image Reference 2 (Image Shack link Below)

-----Attempt 3
Right Click .zip File >> Open With >> Select Default program. Trying to reset it as a zip using this method, the "use this as default" check box is greyed out and not checked. Refer to Image Reference 3 (Image Shack link Below). However It will open the .zip if i select Windows Explorer to open the .zip. It just wont set the default file association to be windows explorer.

Additional Information https://imageshack.com/a/q2B4/1 Refer to Image Reference 4 (Image Shack link above)

Question: How do i change back the .zip file association to default, given the above constraints and with out downloading a program online to resolve the issue?

Windows Registry Editor Version 5.00





"Content Type"="application/x-zip-compressed"






@="Compressed (zipped) Folder"










@="Compressed (zipped) Folder Menu"









Save the above as a .REG file (for example W7ZipFix.reg), double-click it, press Yes twice to dismiss the UAC dialog and to continue, then OK. Log off and back on or restart. The .REG file can be deleted once you confirm everything's working properly.

If you want a simple GUI-based approach then you can use something like File Association Fixer instead:


An alternate solution in this case would be to stop using Windows' limited Compressed Folders feature and switch to a better archiver instead, such as 7-Zip or WinRAR.

  • Thank you so much, it means a great deal to me that you have fixed my file association problem. I am very grateful for what you have done. If i may also ask two more questions which are of lesser importance, but what does the above reg file do exactly? Lastly why do you say windows default zip opener is inferior to 7zip or winrar? – 1AntonyAwesome1 Apr 12 '15 at 4:42
  • You're most welcome! The .REG contains an export of all the default ZIP related registry entries. Not just that, it deletes the existing entries first which might be corrupted (all those lines starting with - in the beginning, like [-HKEY_CLASSES_ROOT\.zip]) then creates them afresh ([HKEY_CLASSES_ROOT\.zip]) with the default keys and values. As for why Compressed Folders are inferior, see my answers here and here. – Karan Apr 12 '15 at 4:50
  • Wow, you really know your stuff. Again, thank you for the additional information. You are such a kind and helpful person, it's AMAISING. :) – 1AntonyAwesome1 Apr 12 '15 at 5:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.