0

I've got a Vista x64 box here that throws an error about "authz.dll is corrupt" whenever I start an application. Doesn't seem to hurt the function of the applications, but is very annoying.

So far I did:

  • Malware & AV scans (nothing of note found)
  • chkdsk/f (which failed to auto start on boot, had to force safe mode manually to make it run) which found no errors.
  • sfc/scannow which reported back that errors were found, but it was unable to fix them. It pointed me at a log file that was many MiB of what looked like GUIDs (totally unhelpful).

If I had another Vista x64 box laying around, I'd just try and replace authz.dll with another copy, but unfortunately I do not. Googling comes up with a ton of hits that look like scammer sites and none that feel legit.

I don't know when it started as the owner didn't even know it was an issue. Reports were just that "it crashes a lot" (RAM needed reseating, was only detecting all chips about every tenth boot). So, not sure where to even start if I need a system restore. Might be so far back that it wouldn't work anyways.

Any tried and true methods for fixing this obnoxious authz.dll popup?

  • 1
    You will need a Vista install Disk and use that along with SFC to fix the corruption, your WinSXS is corrupt, so it might be also easier to just reinatall windows or upgrade to 7 to fix the problem – Ramhound Apr 10 '15 at 19:40
0

It's still a bit of a mystery, but the problem no longer exists so I figured I'd better document it in case someone else has a similar problem (and to close it).

I found instructions at http://www.sevenforums.com/tutorials/42776-extract-files-windows-7-installation-dvd.html regarding how to extract DLLs from the original DVDs for Windows 7. I operated under the assumption that Vista would probably be, if not the same, very close. I was able to locate a Vista install DVD of the appropriate level. I extracted the main file, parsed the XML, found that my index is "3" for Home Premium (the user's licensed level) and then extracted the authz.dll files into a pair of folders (since I need the 32 AND 64 bit versions based on the errors I'd been seeing).

At this point I suddenly realized that nowhere in this process had I seen the authz.dll warnings... Thinking back, I had not seen them since setting 7-ZIP as the default for extraction on all items (3rd task in the linked instructions). Full shutdown/reboot and the machine is functioning perfectly. I did set aside the extracted DLLs in case it decides to act up again. I don't see how the simple act of installing 7-Zip and setting it as default extractor could possibly have fixed it, but that's definitely when the problem disappeared. FWIW, YMMV, etc!

  • By installing 7-zip you solved the corruption issue. Its complicated and outside of the scope of this question. – Ramhound Apr 10 '15 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.