2

As stated in the question, when I connect my USB flash storage devices, the removable devices list won't even show the device in the list. While it does show other USB devices like the USB internet dongle, camera and the finger print scanner, but not the USB flash drives. While everything was working fine before last night, when all of a sudden the connected drive failed, I didn't know why, but then I tried to reconnect the device by physically unplugging it from the computer and then connecting it again, the device gets recognized by the host perfectly, no problems at all, but the vmware removable menu won't show the device.

System info:

  • Laptop: HP Probook 450 G1 (Core i7 variant, with Intel graphics)
  • Host: Windows 8.1 Professional
  • Guest: 10.10.3 OS X Yosemite
  • USB Drive: Kingston G4 (USB 3.0) and HP thumb drive (USB 2.0)
  • vmware tools installed
  • vmware Workstation 10

Here's what I have tried:

  • 1) Restarted the vm
  • 2) Restarted the vm and host
  • 3) Restarted all the vm services, then shutdown the vm and restarted the host
  • 4) Re-installed the USB root hub and USB root hub (xHCI) drivers and restarted the host.

EDIT: I restored the vm to an earlier snapshot and it is now working fine, but I'd still want to know what went wrong and what can I do in the future to avoid this issue?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.