2

I have a hard drive from Western Digital (model: WD2500BEVS-75UST0) that is running without visible problems inside my laptop connected with SATA. However, once I connect it with an external case that converts SATA to USB, I have troubles. The external case that I am using is: BIGtec 2.5" USB3.0 Portable SATA Hard Disk Enclosure (BIG152).

First of all, I formatted the disk when I use a direct SATA connection to my laptop (tried NTFS and FAT32 file system). Then, when I plug the hard drive to my Linux Mint laptop using USB (with the BIGtec Enclosure), it does not become automatically mounted but shows up in the disks utility. However, the filesystem is not recognized there and the format option is visible, but does not work. To investigate the situation further, I was running fdisk /dev/sdb in terminal (sdb is the hard drive connected via USB) and get the following message:

fdisk: unable to read /dev/sdb: Input/output error

Does anybody have an idea what I could further try? I am already using the BIGtec enclosure for another hard drive (NTFS file system) where everything works fine. Do you think it might make sense to try a different enclosure anyway?

Thanks for any responses!

Update #1:

I would like to additionally emphasize that the drive does spin up! Furthermore, here you can see a picture of the two hard drives that I am using and also of the SATA->USB connector. Both hard drives are very similar and I could not even find out the real difference. However, as depicted, the left drive is recognized and mounted without any problems while the right drive is recognized but cannot be mounted nor formatted.

Picture of the two hard drives in use.

By saying that the right hard drive is recognized, I mean that it shows up using the Disks tool under Linux as you can see in the screenshot.

Disks tool shows recognition of the hard drive

On first sight, it seems like the file system is not even recognized. That's why I tried to format it with NTFS file system. What you see is the failure message and that magically a (physically not existing) second hard drive shows up in the Disks tool. I really don't have any explanation what's going on here...

Configuration for the NTFS formatting Failure message when trying to quick format using NTFS Disks tool after tried NTFS format, a second (non-physical) drive appeared

As I also was concerned that the hard drive might broken, I was running an extensive badblocks test while connecting the hard drive directly to the SATA port of my laptop. The test that I was running I called by

badblocks -vsn /dev/sdb

and the result that showed up after more than 12 hours testing was

Pass completed, 0 bad blocks found

Thus, the drive seems to still be working correctly... Any suggestions?

Update #2:

According to Jarmunds suggestions, I did the following:

First: I ran the lsblk /dev/sdb, output is

NAME MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sdb    8:16   0 232,9G  0 disk 

Second: When connecting the drive via USB in windows, the drive spins up, it seems like windows looks for drivers for the drive and installs them successfully. However, there is no drive appearing in the file explorer. Thus, I went to the disk management utility which told me that the drive needs to be initialized (see following screenshot).

Disk management utility asks for initialization of the drive

No matter which of the two options I choose, a CRC error appears (sorry for the German). CRC-error

Afterwards, the disk is shown in the utility but as it has not been initialized correctly, it is also not possible to format it.

enter image description here

Third: dmesg right after connecting the device returns:

[17152.892960] usb 3-1: new SuperSpeed USB device number 10 using xhci_hcd
[17156.597275] usb 3-1: New USB device found, idVendor=174c, idProduct=5106
[17156.597282] usb 3-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[17156.597286] usb 3-1: Product: AS2105
[17156.597290] usb 3-1: Manufacturer: ASMedia
[17156.597293] usb 3-1: SerialNumber:      WD-WXEZ07H42312
[17156.598247] usb-storage 3-1:1.0: USB Mass Storage device detected
[17156.598687] scsi12 : usb-storage 3-1:1.0
[17157.595759] scsi 12:0:0:0: Direct-Access     WDC WD25 00BEVS-75UST0    01.0 PQ: 0 ANSI: 5
[17157.595988] sd 12:0:0:0: Attached scsi generic sg1 type 0
[17157.596173] sd 12:0:0:0: [sdb] 488397168 512-byte logical blocks: (250 GB/232 GiB)
[17157.596412] sd 12:0:0:0: [sdb] Write Protect is off
[17157.596414] sd 12:0:0:0: [sdb] Mode Sense: 23 00 00 00
[17157.596648] sd 12:0:0:0: [sdb] No Caching mode page found
[17157.596652] sd 12:0:0:0: [sdb] Assuming drive cache: write through
[17157.599898] sd 12:0:0:0: [sdb] No Caching mode page found
[17157.599904] sd 12:0:0:0: [sdb] Assuming drive cache: write through
[17157.600434] sd 12:0:0:0: [sdb] Unhandled sense code
[17157.600438] sd 12:0:0:0: [sdb]  
[17157.600439] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[17157.600441] sd 12:0:0:0: [sdb]  
[17157.600442] Sense Key : Medium Error [current] 
[17157.600445] sd 12:0:0:0: [sdb]  
[17157.600447] Add. Sense: Unrecovered read error
[17157.600449] sd 12:0:0:0: [sdb] CDB: 
[17157.600450] Read(10): 28 00 00 00 00 00 00 00 08 00
[17157.600457] blk_update_request: 154 callbacks suppressed
[17157.600458] end_request: critical medium error, dev sdb, sector 0
[17157.600460] quiet_error: 154 callbacks suppressed
[17157.600462] Buffer I/O error on device sdb, logical block 0

Note that the lines starting from Medium Error[current] are shown repeatedly in the following lines of dmesg that I didn't paste in here

Thank you a lot for your support here Jarmund!!

Update #3:

Out of desperation I organized 2 additional External HDD Enclosures to test whether it might work with a different hardware. The ones I tried now were:

  • SITECOM USB 3.0 SATA 2.5" hard drive case
  • ICY BOX USB 2.0 SATA 2.5" External HDD Enclosure Model IB-231StU

I specifically decided to take one working with USB 2.0 and one with USB 3.0. However, as none of these worked neither, I decided to sell my hard drive to people who want to use it with the SATA interface directly. Thus, I won't be able to test out future suggestions.

1

I had a similar problem using 4 of this cases and 2 of this hard drives. Only one of the 4 identical cases accepted a WD30EZRX drive. When attached through the other 3 cases, the computer reported a 2.2 TB hard drive and a 0.8 TB hard drive of unknown partition table – instead of a single 3 TB drive with intact GPT partition table. I found out that the vendor of the cases only supports hard drives up to 2 TB capacity (using that type of external case) and so I think I had just luck having 1 working case.

Long story short: Be sure that your case vendor supports hard drives of your desired size.

  • Well I think the size of 250GB should not have given any trouble as I bought the cases at a time when TB hard drives already were around. However, meanwhile I sold the drive to be used as an internal drive. I would keep the thread open anyway in case that somebody faces similar issues... – tc88 Oct 6 '15 at 10:22
  • @tc88: I tried also this case using the above mentioned drives – although the case supports drives up to 8 TB, mine did still not work. Technical support of Sharkoon found out, that the internal usb chip set has problems with the WD••EZRX series in general. So maybe you had also just a bad combination of disk and case. However, I'm posting this just for following readers. – user3389669 Oct 7 '15 at 13:54
  • If I remember correctly I even tried one or two additional cases apart from the one shown in the picture of my first post. After those also didn't work, I decided to sell the drive. I'm sorry that I didn't document the test of the other cases. Thanks for your remarks anyway! – tc88 Oct 8 '15 at 14:26
0

Harddrives of the old fasion RPM type are normally very power hungry. Are you sure your USB port can provide enough current?

I've seen some hardware vendors bragging about their hardware having USB port, but fail to mention that the USB3 port does not actually supply the 900mA as dictated by the USB3 standard.

Also, while USB3 devices are technically backwards compatible with USB2, they all fall short if they require more current than what USB2 can provide.

Things to try:

  • When powering up/connecting the drive, turn it around a bit, to see if you feel that distinct gyroscopic effect of the harddrive actually spinning up. I've seen drives connect just fine, but they refuse to spin up if not provided enough current.
  • If it fails to spin up, try connecting to a different USB port (The one directly on the mainboard, not the externally attached ones that go in the chassis). And of course, make sure it's an actual USB3 port (should be blue)
  • If it still fails to spin up, regardless of the port, try connecting it via a powered USB hub. These are often able to provide the extra current needed if the mainboard fails to do so. Again, make sure it's a USB 3 hub, so that it'll actually provide the full range and not skimp on the juice. If you do this, it might even work if you plug it to a USB2 port on the PC end. I'm using a Sandstøm USB3.0 Hub for this exact purpose, so that my android tablet with only USB2 can work with a 1Tb external drive.

It should be noted that I've seen Android claim that there's a problem with the file system itself when the current was the issue, so as long as it's formatted properly, I wouldn't suspect the filesystem.


RE: Update #1

One of them works, the other one doesn't but they have the same voltage and current specs, so at this point I doubt that it is an issue with supplied power.

A couple of things I am curious about:

  • what does lsblk /dev/sdb say?
  • I can see that mkfs complains about trying to make a filesystem on sdb, as it's the entire drive as opposed to one partition. Is this an artefact caused by the graphical tool you're using? I exclusively use fdisk or one of its derivatives, but from what I understood, you already tried that, fdisk /dev/sdb gives you I/O Error?
  • Are you able to connect the drive via USB and format it in windows?
  • What does dmesg say once you connect the drive?

RE: Update #2

Unfortunately I'm at a loss at this point, as I do not see WHY it is failing. Only thing I can tell you is that it clearly fails to read anything from the drive, indicating that a filesystem, or lack thereof makes no difference as it can't even get past the first sector.

Normally I would suspect disk death, but seeing as it works fine when not connected via USB, that can be ruled out.

  • The thing is that the drive actually does spin up. I edited my original question adding some more details, pictures and screenshots, maybe you have another idea? – tc88 Apr 14 '15 at 18:10
  • @tc88 While this is a setback, I'd like to at least try to pinpoint the error. Updated my answer accordingly. – Jarmund Apr 14 '15 at 18:26
  • To your question whether fdisk /dev/sdb gives me I/O Error, I have to answer with yes. I already also mentioned that in my question. For the other approaches you suggested, please see Update #2 – tc88 Apr 14 '15 at 19:51
  • Thanks a lot anyway! I guess I cannot mark your post to be the correct answer as the problem has not been solved right? Once I find a solution, I will come back here and tell about it... – tc88 Apr 14 '15 at 20:55
0

Unfortunately the following approach didn't help to my problem, but it might be interesting for other users.

When I compared the two hard drives shown in my question, I recognized that they are using different jumper configurations. Thus, I did some research on this and found the documentation about the jumper settings. I realized that the working hard drive was configured like in setting 3 for Reduced Power Spinup (RPS) enabled. I thought this might be interesting for me despite the fact that the spinup of my drive seemed to work correctly. I also found a datasheet about the RPS itself which is available here.

After changing the jumper settings for my not working disk to the one of my working disk I tried the 3 different enclosures again but could not get any working configuration. However, I hope that it at least helps some of you out there!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.