0

I have Windows XP Pro x64 and I use Firefox as my browser.

When I go to http://www.weather.com/weather, there are videos listed on the right hand side. I used to be able to click on the video title and they would open. I had a problem with my pc and had to do a system restore to after Adobe was installed but the files at this website stopped opening. All I get is a black box. I uninstalled Adobe and reinstalled these programs one at a time but the files still don't open:

  • Adobe Flash Player 17_a
  • Flash_player_ax Flash Player for Internet Exporer - ActiveX (I occasionally use IE8)
  • Adobe Flash Player - Active-x for Windows
  • install_flash_player NPAPI for Firefox
  • Adobe flashplayer17ax_a_install
  • Adobe install_flashplayer17x32_aaa_aih
  • Adobe Shockwave Installer Slim 12.1.4.155

They're the latest versions from the Adobe website.

In Add/Remove Programs, Adobe Flash Player 17 Active X and Adobe Flash Player 17 NPAPI are listed but there's no size to them, the "Size" field is blank. The other Adobe programs that I installed aren't even listed there, and it's the the same with Revo Uninstaller.

I ran Avast, BitDefender, MBAM, Avira, SecurityCheck, and Spybot S&D and they showed only cookies so I don't think it's a malware problem.

Can anyone give me some help?

  • 3
    Your operating system isn't maintained since April 2014. You should consider upgrading to a modern version of Windows because Microsoft won't be releasing any security updates. Windows XP is not secure anymore even if you have antivirus program etc. – gronostaj Apr 13 '15 at 11:10
  • You didn't answer my question. Why'd you bother? – user437092 Apr 13 '15 at 11:14
  • 1
    He didn't leave it as an answer. Just a comment. A very valid one too – Joe Taylor Apr 13 '15 at 11:21
  • I'm not looking for comments, I'm looking for answers to my question. – user437092 Apr 13 '15 at 11:39
0

It sounds like the Flash Plug-in is disabled. To enable it,

  1. use the menu button to choose Add-ons
  2. In the Add-ons Manager, select Plug-ins on the left
  3. Find Flash in the list and choose Always Active

There is good troubleshooting information at Mozilla's site - Flash Plugin - Keep it up to date and troubleshoot problems

  • I don't have a problem on IE8 x64 playing the videos on this page – user437092 Apr 13 '15 at 13:59
  • That information is good to know, but this answer is for Firefox, as your question requested. Is the plug-in set to always active in Firefox? – CharlieRB Apr 13 '15 at 14:06
  • Thanks for responding, Charlie. I don't have a problem on IE8 x64, Firefox or Chromodo playing the videos on this page wfsb.com/global/… but none of the browsers can open videos at weather.com/weather. I don't know what the difference is between the sites tho. In Firefox, I have all my add-ons enabled. – user437092 Apr 13 '15 at 14:06
  • 1
    That is not what your question states. The way it is written, you lead us to believe there is a problem with the Flash plug-in. If you had told us that other sites play flash in all your browsers, I would have taken a different approach. Please edit the question to be accurate to the problem you are having, including all the details. – CharlieRB Apr 13 '15 at 14:09
  • My initial question is correct. There was a problem with my Flash Plug-In. I think you misunderstood my last comment post. I followed the link you gave me support.mozilla.org/en-US/kb/… and it led to "The Refresh Firefox feature." It fixed the problem with Adobe Flash. Videos now open at The Weather Channel on Firefox. I didn't check IE8 or Chromodo because I use Firefox 99% of the time. Thanks for your help. – user437092 Apr 13 '15 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.