3

The entire installation process seemed successful without any errors, and yet upon first boot, after completing the "getting devices ready" stage, it goes into a "Getting ready" stage and hangs with the little dots spinning.

This is an upgrade of Windows Server 2008 on a WM Ware Virtual Machine. At first I thought it was an issue with Windows Server 2012 not being supported on VM Ware version 7, but after upgrading to VM Version 9 (ESXi 5.1), the same exact problem occurs. It just sits there and spins forever at "Getting ready".

Does this indicate something is wrong, or should I just wait longer? It's been sitting there for at least half and hour already. The first time I tried this, I just powered it down and tried again and it said the installation could not be completed because it was interrupted, so I had no choice but to revert to the old OS, upgrade the VM version, and try again. But I'm right back at this "Getting ready" screen again.

  • I experienced the same thing on bare metal. I was contemplating a reboot, when finally it came back to life and rebooted on its own. Facts: in my case, I had not wiped the drive -- I was in that situation in which the OS offers to leave you with the windows.old folder Also, the BIOS on the server when back to Nov 2008. I also suspect it may have been testing for linux devices and trying to install drivers for them (?) because when you run HP's SPP (Support Paq for Proliant) it will probe the system and try to determine whichof the500drivers HP might deem the server to need IFlinux were loaded. – user459492 Jun 16 '15 at 16:22
2

I decided to just wait it out this time. After almost an hour, it finally finished successfully.

I have no idea why it took so long. Perhaps it was some kind of network timeout. After upgrading the VM hardware, I noticed the network card must have changed, because I lost all my network settings (IP addresses, VPN settings, etc.). I'm going to try to recover them from the registry settings for the old card if possible. Anyone know of any good utilities for doing so?

  • Had the same problem, did exactly what you did and just left it to play the second time - there were some errors to clear up but seems to be stable enough to move on to Server 2016 > 2019 upgrades now – gchq Dec 9 '18 at 19:23
0

I experienced this as well going upgrading from Windows Server 2008 R2 to Windows Server 2012 R2. Watching that Getting ready sit there forever was maddening and I was about to punch the monitor. But changing the NIC (network/ethernet) card worked. I was using VMware VMXNet 3 removed that and used Intel E1000 instead. That worked like a charm. What a PITA though!

0

Establish a link with your disconnected NICs. This "problem" goes as far back as SBS 2000 or 2003, AFAI remember.

If you're an integration house or system builder, keep a cheap powered-on switch nearby. It isn't looking to make connection to anything. It just needs a link status of not disconnected.

danielkr

0

Can confirm this also happened when I tried to in-place upgrade our DC from 2008 R2 to 2012 R2. Disconnecting the NIC in VMware immediately resolved the "Getting Ready" freezing issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.