0

Basically i'm helping out at the offices where family works. They have this backup server computer - which is running Ubuntu 10.04.2 LTS - which they apparently in the past could just turn on and then they could make backups from their windows computers.

This is not my forte at all and I assume it appeared simply like a network drive/share that they could access. But, when I connect it now it only boots up in command line/cli mode with no gui with a login screen. and it doesn't appear on other computers when network discovery/file sharing is turned on etc. I really want to be able to access the standard ubuntu gui like I can when using the Ubuntu livecd (I have burned the Ubuntu 14.04.2 LTS iso to disc). When I click the install option from the livecd it asks whether i'd like to upgrade the current ubuntu to the livecd version (14.04.2) - im not sure if this would add the gui or not. and it says "will clear system-wide settings" so I'm worried this will stop the backup/server settings from working, not sure. OR ideally I could just add the gui to the current computer without having to upgrade/install, as im paranoid of ruining the backups on the hard drives. (no external drive to back everything up to) please help?

I have tried logging in and doing commands like startx etc but it doesn't work.

tl;dr: I just basically want to access the normal Ubuntu gui mode and get this server running again. technically minded but do Not have any real experience with linux at all except with simple tasks

  • what happens when you log in from the command line? – Russell Uhl Apr 15 '15 at 13:20
  • it just gives a prompt/command line console after I log in. – totallylost Apr 15 '15 at 13:48
1

First make sure X server is installed - if startx command is not found, it probably isn't. In that case install it with:

sudo apt-get install xorg openbox

Replace openbox with the windows manager of your choice. You may also want to install xauth and ubuntu-desktop, but I'm not an expert in Ubuntu in particular.

Sidenote: I assume that this server is able to install software from Internet repositories. If it can't, you'll have to setup usable repositories, either on the Internet or on your Live CD.

If X server is installed but won't start, check /var/log/Xorg.log for errors. Google those errors up and come back here if you don't find any solutions.

| improve this answer | |
  • thank you so much. - I'm not sure if it can connect to the internet, when I do login at one point it says "58 packages can be updated", suggesting to me it implies that it could connect to the internet to see these updates, But every single other sign looks as if it can't connect, because for example "ping google.com" returns "ping: unknown host google.com", when I try your commands it loads a bunch of things but then stalls on trying to connect. Its connected right now to a router via a ethernet cable. The internet connected fine immediately just now when I was using the livecd. facepalm. – totallylost Apr 15 '15 at 8:50
  • If you have troubles with network connection, you can start by reading ubuntuforums.org/showthread.php?t=25557 – Dmitry Grigoryev Apr 15 '15 at 8:53
  • ok thanks so much, I will read through this. This isn't my area at all but for all intents and purposes im the 'computer guy' so I just have to wing it/improvise and see if I can more or less do what needs to be done. – totallylost Apr 15 '15 at 8:56
  • Alternatively, you can try to install packages from your LiveCD, but I'm not sure it will work since versions are different. If you still want to try, add your cd/dvd mountpoint to /etc/apt/sources.list (hopefully there will be examples inside that file) – Dmitry Grigoryev Apr 15 '15 at 8:58
  • I tried commends listed etc but nothing in that article helped fix the internet issue. it explains how the commands/functions work but not really how to fix any issue. i wonder if it for some reason cannot connect through the router, though the livecd can with no problem. the problem in these specific offices its far from any working ethernet ports so Im only able to connect via wifi/router located in the next office. I wonder if doing the upgrade install option would add this gui mode. I tried commands I read about like sudo apt-cdrom etc to add it but I got "no valid records were found" – totallylost Apr 15 '15 at 9:37
0

Im surprized nobody mentioned it already but I would try typing " ifconfig "
at the command prompt to find out the computers IP address and put that into the browser of another computer and see if I could login that way

| improve this answer | |
  • I can't now but I will try this tomorrow, thank you! – totallylost Apr 15 '15 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.